Overdrive Media Console - updated Fuze firmware and can no longer download audiobooks

I have been downloading audiobooks from my public library and transferring onto my Sansa Fuze 8G using Overdrive Media Console for several months and have not had any problems - surprisingly simple to do and love the Sansa for book listening.


However, tonight when I connected my Sansa to my computer, I was directed to download the latest firmware upgrade to the unit.  After doing so, I cannot transfer my downloaded audiobooks from today to the unit.  I tried re-transferring a book that was downloaded several days ago and it still works fine.  With the latest downloads from the library, Overdrive gives me the following message:


“Error details:  Unable to transfer the selected title because [insert] returned 0xC00D2779”

I thought it might have to do with Windows security and so ran the Windows Media Security Upgrade but that was not the issue.


I reloaded Overdrive Media Console but still cannot transfer the books.  The error message now reads:


“Error detail:  Unable to insert selected title.  Error 0xC00D2779: the file could not be transferred because the device clock is not set.”


The clock is set on the Fuze and I have tried resetting it (never know!).  The books still do not transfer and same error message comes up.  If it helps, I am running on Windows XP and the Sansa version shows as V02.03.33A.


Can someone here help with this problem or does it seem to be strictly an Overdrive issue that I should take up with them? 


Thanks in advance.

My experience is you can’t set the clock manually.  While online, hook up the Fuze and transfer something meaningless (any random non-DRM file) to it using *Windows Media Player*.  This seems to set the internal clock (but you must be *online* while you do it - it updates the clock from the internet).

I’ve noticed the Fuze is particularly sensitive to getting the clock reset for some reason (For some reason, my Clip hasn’t had the clock reset nearly as often as the Fuze has).  I don’t have “always-on” internet and I’ve noticed just about every time I open WMP with Fuze attached & no internet connection, it resets the Fuze’s clock, resulting in Overdrive “device clock not set” message.  It’s a big hassle for me to get the clock reset (to find an internet connection).  What I think is happening: When you open WMP it seems to search for all attached devices and set their internal clock to internet time - and you’re out of luck if you don’t currently have an active internet connection (I consider this a bug in WMP, but I haven’t confirmed it).  I make sure I don’t open WMP with any Sansas attached.  Ever.  (Anymore.)  And my Fuze’s internal clock has stayed set for going on 6 months now. (It was previously getting reset about every week or two.)

My second thought (actually, probably the initial problem) - Updating firmware resets a lot of stuff back to the defaults.  The Fuze’s USB mode was probably set back to the default (Auto-detect, not-so-affectionately known as “auto-defect”).  Go into Settings|USB Mode and set it back to MTP so OverDrive can use it, and try again.

Good Luck.

1 Like

Thanks sooo much kmk_01kmk.  I must admit I was very skeptical of your offered solution because I don’t use Windows Media Player.  Nevertheless, I followed your instructions and low and behold my audiobooks are now transferring from the Overdrive Media Console as they did before. 

Thanks again!!

Glad it worked for you!  Perhaps there is *something else* that can reset the Fuze’s clock, but I know since I made the conscientious decision not to open WMP directly, the Fuze’s internal clock has stayed set for DRM purposes. 

Greetings. are you still having problems downloading audiobooks to yer Fuse?

no longer a problem.  Am greatful to kmk_01kmk for solving the issue for me…see solution above.

Thank you so much!  This has been driving me batty for hours now.  Just found your answer and it worked perfectly!

Hi, I have a sanza m250 and I’m getting the same errors when transfering wma books in overdrive media console. I first formatted it in My Computer and got an error saying it didn’t support wma format. So I installed the sdmx3-iv001 exe file and that didn’t help. I can add mp3 audio books using overdrive media but not wma. I also tried doing what you suggested in windows media player by adding a song to my mp3 using windows media player then trying to transfer a wma book again using overdrive and get the same error… I am using windows 7 and my m250 doesn’t have a clock on it to set the time. Can you help me?

thanks in advance

I’m not familiar with the m250.  On OverDrive.com, I didn’t find it listed as a supported player, but I found the e250?  http://www.overdrive.com/resources/drc/Default.aspx

I’m sure that’s not an exclusive list, but I’d make sure the m250 is compatible before investing too much time into it.

I have a Sansa Fuze 4 GB player, and I am getting the same error message (Error 0xC00D2779: the file could not be transferred because the device clock is not set).  I’ve tried the suggested fix, but I’m still getting exactly the same error message when I attempt to download from Overdrive.  Moreover, the clock is not sync-ing - in fact not changing at all - when I sync the player using Windows Media Player. 

Based on some other threads, I have updated firmware, reformatted, tried switching back to factory settings, switched to MTP mode, sync-ed using WMP (version 11).  I’m at my wit’s end.  Any other suggestions? 

Thanks in advance!

  • Dan

Time to call 1-866-SANDISK and ask the pros.

Like many others I tried all the other suggestions (reloading overdrive, formatting from WMP11, etc.), but none worked. On a whim I switched the Fuze USB setting from MTP (recommended) to MSC, which is supported by Overdrive and WMP11. Don’t know why, but it transfers fine now. To me this indicates that the problem is not the Fuze clock, nor Windows DRM, but some bug in either Fuze or Overdrive.

Thank you! I did not know how to do the sync-ing but I tried your simple solution and it worked! After that I found a blog reporting a link between Windows Media Player 11 and Sansa download problems. It recommends rolling back to an ealier Windows Media Player version. I’m trying that too.

Rolled back to Windows 10. MP3 transfers on USB AutoDetect but not WMA. The best suggestion so far is to try the alternate USB settings for WMA transfers.

Thanks, kmk_01kmk.  Your suggestion also took care of the same issue I was having with my Sansa Clip Zip after a firmware update.  Worked like a charm.  Don’t know what the process would be, but this “little jewel” should be shared with the Customer Support folks that answer the phones.  Their suggestion to format my device and reinstall the firmware got me no where of coarse.  Their next suggestion was to REPLACE the device.  Excellent work!

If you have a Sansa Clip Zip and you get this message:

“Error detail: Unable to insert selected title. Error 0xC00D2779: the file could not be transferred because the device clock is not set.”

Here is how to fix this problem in less than a minute: Set the clock on your device.

  1. Turn your device on

  2. Click Menu tab top left of all tabs

  3. Scroll through menu options to Settings

  4. Click center tab to enter Settings

  5. Scroll down Settings to System Settings

  6. Click center tab to enter System Settings

  7. Scroll down System Settings to Date

  8. Click center tab to choose Date

  9. Set Date correctly and press center tab to save and return to Sys Set

  10. Scroll down System Settings one more notch to Time

  11. Set Time correctly and press center tab to save

Your done. Your Zip will now accept anything from OverDrive Media.

Enjoy your audio books!