Not more than 50 songs

Ok, as title says, my Sansa Fuze (5 months old) won’t load or at least show more than 50 songs. 
A few days ago my brother downloaded Itunes program and that changed most of the formats to some wierd mp3 format which shows up as mp3 but it can’t be read by my cellphone (nokia 5300 express music, old veteran) nor my mp3. I unistalled the itune programme and the formats seem to have gone back to normality, but the fuze, or the cellphone, still didn’t read the songs. 
I came here to the forum and read some people had a similar problem and it had been suggested to delete the data base (a .sys file), and it was supposed to re-appear once I refreshed the media files. 
Now, the fuze doesn’t show more than 50 songs and doesn’t let me listen to the stuff i download and transfer.

Might not be the best english here, but tried my best. Hope somebody can help x)

Edit: Ok, the 50 songs thing isn’t a problem anymore…being juggling around with it and sorted it out. Although i still have this problem about the songs format being mp3 but not being read as actual mp3s. They show up on the mp3 player…but when they have to be played they seem to be 00.00 - 00.00 as if there was no song and it gets skipped.  

Message Edited by majingo on 08-31-2009 03:26 PM

No reply yet…anyway, tried to format the fuze but problem is still there, no matter how many songs I put on the mp3 player, when i turn it on it will only show me the last 50 songs i uploaded.