Not enough space for music DB. Please free 200MB"

I got the above message when I turned on my Clip Zip 4GB. I have a MicroSDHC 32GB card installed for more memory. While selecting files to copy I mistakenly thought the Clip Zip would automatically know when to stop copying to the 4GB Internal memory and transition to the 32GB External memory. I was wrong and my music management program (Media Monkey) froze. After rebooting my computer I tried connecting my Clip Zip and the computer wouldn’t recognize the device. Media Monkey though it was a ClipZ and wouldn’t let me change anything on the Clip Zip. Tech support emailed me to format the Clip Zip but that changed nothing. Finally I went to the Clip Zip and into it’s settings and selected “Format”. Now everything is working fine. I hope synching Audio Books isn’t this problematic.

Not as long as you remember that YOU have to tell it where to place the files; it won’t automatically fill up the internal memory, then switch to the card.