No sound from sansa clip+

I have a 5 month old sansa clip+ that has stopped giving out any sound. The screen says it’s working, has all the normal display but no sound, have tried several earphones and stereo speakers. Looking at the headphone hole there is evidence of slight damage, ie where the baby may have tried inserting the headphones too forceably at the wrong angle. Is this likely to have damaged the inside? Anything I could do to it? as I assume the warranty would be invalid.


Are you sure it’s just not on PAUSE ?

Definately not on pause, however have realised it’s not that there is NO sound it’s just very low, so some tracks that are quite low volume played on anything now have no sound, other tracks play much quieter than before. The volume is set to ‘rest of the world’ but the tracks have always been audible previously.

Is the Volume option set to HIGH in Settings?

Yes, the volume has always been fine previously.

If you haven’t yet done it, try a reset of the player (hold the on button down for 30 seconds or more).  Also, try a reapplication of the firmware (the code can become corrupted)–see the firmware upgrade sticky thread at the top of the forum. 

thanks, I’ll try them.

OK, I’ve updated the firmware and tried the reset. I have two other clip + (1 for me, 2 for the kids) - Comparing them,  the volume on the affected one at max is about what it is at half  volume on the other two.

@undergrounderni wrote:

Yes, the volume has always been fine previously.

But you didn’t answer my question . . .

@tapeworm wrote:

Is the Volume option set to HIGH in Settings?

There is a Volume option in the Settings menu for either NORMAL or HIGH. Check to see that it is set to HIGH.

Sorry, I wasn’t clear.  Yes it is.

OK, my son is happy he can now hear his mp3 again. However I still feel it has a problem as the volume is so low compared to my other two players. Does anyone have any idea why that might be the case or have I now exhausted the possibilities?

Glad I found this post!  Could not figure out why I had sound then didn’t.  Found the pause button and that solved my issue.

Also found that for my bluetooth Bose headset work with the unit I had to have something plugged into the headphone jack; a short jumper or a wired headset.  Once it’s plugged in and using the wire as an antenna, the bluetooth headset works fine.