No response from Sansa Clip+ after resetting.

After attempting to reset the clip+ when it froze on the “refreshing media” screen, the screen turned off and I proceeded to switch on the player only to find no response from it. I’ve tried resetting the player several times and the screen showed no feedback at all. It is also no longer recognised by my pc normally but is able to enter forced msc by holding the centre button upon connecting to the pc. I’ve tried to format using windows under forced MSC but I’m totally clueless as to what I should do now. Can anybody offer some advice on how to revive my player? Thanks in advance.

So your player is recognized by the computer under force MSC mode, but you can’t format it.  Hmm.

Some people have reported that holding the power button and the home button down at the same time can start the player up again.  Or the power button and the center button.  See if that will allow the player to boot up completely.  Then you can either format it through the computer or delete whatever you recently put on there.  Hope this helps.

I am having the same problem and have tried everything. nothing is working.

It seems I am able to do a full format under forced MSC after trying out again today. How do

I get the firmware installed at this point?

To reapply the firmware, see the firmware upgrade sticky thread at the top of this forum–the firmware and instructions are there.

Not sure if I’m doing something wrong but the sansa updater doesnt detect the player in forced msc mode and putting the update binary file into the root in forced msc doesn’t seem to do anything to the player either. Any help is deeply appreciated.

The easy solution simply is to manually apply the firmware upgrade–no Sansa Updater needed, consuming computer system resources. Once again, see the firmware upgrade sticky thread at the top of the forum–the firmware and instructions (simple) for the manual installation of the firmware are there.

Sorry if my phrasing was too awkward but what I meant was I’ve already tried both the updater and manual application of the firmware but to no avail. I belive the manual application was simply putting the extracted file into the player? There has been absolutely nothing appearing on the screen on my clip+ and I’m on the verge of giving up soon. 

Why not call SanDisk Tech Support? They are not only trained, but paid just to sit around waiting for people like you to call them with questions/problems.

You might interrupt their angry birds game, but they can always get back to that. :stuck_out_tongue:

I’m not assuming anything, but you might want to make sure that you are following the firmware upgrade instructions exactly–sometimes, we can easily overlook a step. For example, when you download the firmware to your computer, you have to unzip the zipped file that you have downloaded, and then copy/move the now unzipped .bin file that you will see to your player and then disconnect–some people forget to unzip the downloaded file.

I’m pretty sure unzipping was the first thing I did to the zip file. Can’t be that hard to put a .bin file into a removable disk and then disconnecting. You guys have been really friendly and willing to help but I guess I should get a replacement soon :neutral_face: