No MP3 Sound from Sansa clip

I solved this problem for my mom today and wanted to post what happened along with the “fix” for anyone who might have the same issue.

Brand new Sansa 2GB Clip bought in Dec. '08 from Dell–she had it three weeks and suddenly this last week, she got no sound coming from the player.

Remotely, I went through some usual troubleshooting: 

  1. Make sure the headphone jack is “all the way” in

  2. Swap out earbuds for known good ones

  3. Make sure volume is up

  4. Make sure MP3 player isn’t on pause

  5. Try different mp3 file

  6. Make sure EQ settings are ok

  7. Does FM tuner work? = Yes  

That last one signaled to me it was definitely a software/firmware problem, not a hardware issue.

Via the Sansa firmware updater, we updated her shipping firmware from:

2.01.13  to  2.01.16

This worked. She can now hear her MP3s --(though be warned, in upgrading the firmware, it deleted all her data/MP3s).

 I hope that helps anyone else out there with the same issue.