No Drive for SD Card in Windows explorer.


Looking for hours on a problem with the Clip Sport… 

Have always been able to connect the player with it’s cable to the PC to add music…  after an upgrade of the firmware (tried 1.38, afterwards went back to 1.17, …was no solution) windows explorer isn’t able to detect the microSD.  Before the upgrade this was no problem.  Card is Sandisk 32 G class 10.  

When connecting the player to the PC, for a moment I see new drive j:  coming up in explorer, but it disappears right away.

If the player is connected, taking the card out of the player does nothing, put putting it back it’s place gives the dialog  “Please insert the disc in removable disc J:”, with the cancel button.

grrrr, any help is really appreciated ! 

Here are a few ideas to try.

   When your player is disconnected from your PC and the SD card is removed, does your player behave normally?

       (Can you play audio files saved in the internal memory and when you connect to your PC you can see the internal drive folders and files?)

       If YES, then maybe your problems are related to the micro SD card.

       If NO, then maybe your player needs additional problem solving.

If your micro SD card is causing the problems you described, then maybe trying using the micro SD adapter that came with your memory card and connect directly to your PC.  Does Win File Explorer show the standard SanDisk player folders and your audio files?  If not, maybe you can think about using the the Windows Error Check Tool (under Properties -> Tools).

If the file allocation table of your memory card is messed up, you may need to consider trying to reformat (FAT32).

Maybe report back here with your results.

Thanks for reacting so fast !

  • The player on itself behaves ok.  With & without the card.

  • The micro SD card in the adapter is recognised without any problem.

  • Tried after formating the SD card in windows (FAT32) & with the clip sport : twice no success.

Before the upgrade of the firmware I didn’t had the problem.  

Problem is I connected with OTG the Android phone to the player in the morning, before work.  To listen to daily podcasts on the bike ride to the job, but, just like windows explorer, the SDcard isn’t recognised.

I recently had a micro SD card that was giving me problems and it affected the normal start-up of my Clip Sport player.

I resolved this situation two ways.

     I began using a brand new Samsung 16GB micro SD card and my player was all back to normal.

     I used Win File Explorer to complete a full format of my old memory card (using the micro SD card adapter).

          Full format = “unchecked” quick format selection box for FAT32.

          The full format process seemed to repair my old micro card (so far) for normal use in my Clip Sport player.

Thank’s for helping !

Today (first day after my upgrade) … the player suddenly had problems with reading the podcast from the SD card… bought me an old card (< 10)… seems it was the card after all. 

(linked with the upgrade)

So I’m ok, thanks all !

The problem shared in the above forum is very common but many users find difficulties in solving the same.

But the solutions shared in the above forum are very simple and very effective.

I tried some of the solutions and they really work for me.

If you are facing Not responding problem in Windows Explorer, click on the given link to get the problem solved-