No ALB file for MP3 songs

Amazon MP3 songs transferred using Windows Media Player do not contain an ALB file. As a result, I am not able to play the songs from the music folder. The songs can be played if I copy directly to another folder on the sansa, but it will not combine it with the songs transferred from WMP.

Is the ALB file created by the sansa or WMP?

Is the file structure or file tagging of the Amazon song MP3 resulting in the ALB file not being created for the MP3 track?

Would re-formatting  the player resolve this issue?

Can I recreate the ALB file myself?

Alb file? I Googled around for alb and Amazon and found these.

It should have nothing to do with whether the mp3 plays, though I guess having it in the same folder could confuse the Sansa. 

All the Sansa needs to play an mp3 is the mp3. Or, if it has digital-rights garbage attached–and Amazon files aren’t supposed to, they’re just plain mp3s–then it needs the digital-rights info. 

The Sansa looks for mp3s everywhere in its memory, lists the information from the ID3 tags, and plays them. That’s all it does. 

I have e280 version one, and music is supposed to be transferred using WMP to the music folder since the music folder is hidden. Yes, I can copy the MP3 album to a folder other than music and go to the folder and play it no problem. It will not not be picked up under the ALL music menu. Only music with an ALB file are visible to the user under ALL music on the sansa (I like to shuffle my music). I am not sure why ALB files are not being created for amazon mp3 files. What is Media Monkey like?

This is starting to baffle me.

I just searched my Sansa (a Fuze at the moment, same as E200v2). No .alb files.

Are you navigating by folder or by Album, Artist, Song etc.? (That’s a database built from the mp3 tags, and it indexes every mp3 on the unit.) 

Are you using Linux or something that reads the disc differently?

MediaMonkey is an alternative to WMP: rips, syncs, etc. It gets tags from user-generated Freedb rather than the Microsoft database. And if you get the free version, you have to substitute the mp3 encoder lame_enc.dll from  for the one in MediaMonkey, which times out.  

Believe me, it is totally baffling and frustrating to me as well. I know with v2, they had brought drag and drop fuctionality to the music folder but not with v1, which is the player that I own. Music that do not have the alb file are not visible under the music menu. I confirmed that the music is on the player by unhiding the music folder on the sansa.

I am wondering, is the ALB file created by WMP or the sansa player? It sounds like it is created by WMP and not the sansa. If that is the case, it is a WMP issue.

I actually just noticed now that the sansa has some wma music that do not have the alb file.

I think the player got corrupted. All my music from a certain date is not showing under the music menu.  I think re-formatting the player is my next course of action.

Before you reformat, save all your music somewhere.

Are your .wma files from a subscription service, or just ripped from CDs? Because if they’re not subscription tracks, let’s just take WMP out of the picture. Switch to MSC mode, drag-and-drop everything into a folder–Music if you un-Hide folders, any other folder name if you don’t–and you should have no problems. 

The Music that shows on the Sansa display (with Settings, Video, etc.) is not a folder. It is an index drawn from the ID3 tags. Similarly Artist, Album, etc., are not folders. They’re all lists made from reading the tags. So the key is the tags. 

Before you reload, get mp3tag.

It’s free.

As you install it, you have the option to add it to context menus. Allow that. After installing, go to Tools/Options/Tags/Mpeg and set the default Write option to IDv2.3 ISO-8859-1. That makes the tags most readable to the Sansa. You can also set a default to <blank> out comments, which is a good idea. 

Make sure you save the changes, close mp3tag, right-click on an album folder and you should see mp3tag among the options. Click it and it will open the folder of mp3s. Highlight them all, make sure they’re in playing order from top to bottom–you might have to click the Track Number column header–and under Tools use the Auto-Numbering wizard with Leading Zeros .  This will make the tag numbers 01, 02, etc. and also save to ID3v2.3 ISO-8859-1. It took longer to read this than it will to do it.

I do this with every album before loading it onto the Sansa and for that investment of a few seconds, everything shows up nicely.  You may still run into the maximum number of files, but they’d have to be pretty small. 

Message Edited by c1u31355 on 03-22-2010 06:44 PM

Thanks. I think the best thing is to take WMP out of the picture because I think that is where the issue resides. The only thing is that WMP adds a album cover file as oppossed to my amazon tracks embedding the album cover into the actual tracks .

I can embed the album cover using WMP into the WMA tracks by copying and pasting the album cover from the folder jpeg. Can I use mp3tag to add the album cover for the WMA music?

Do you use windows explorer to drag and drop?

Mp3tag can get cover art from Amazon, under Tag Sources.  It can also work with .wma tags, but since I don’t use .wma I can’t tell you specifics. But  mp3tag has a lot of goodies I haven’t explored–download it and click around.

If you save the album cover as a small file called folder.jpg in the album folder it should display properly. I think 200x200 is optimum. 

Yes, just drag-and-drop in Windows Explorer for MSC. Or copy and paste. 

Sandisk just emailed me and told me that formatting the player is my best option. The WMA music is not embedded with the album cover unlike the amazon mp3 songs. I was going to drag and drop the tracks, but I will also have to drag and drop the album art as well. I may just go ahead and embed the wma music tracks with the album art. As mentioned before, the issue is not the amazon mp3 tracks, but the creation of new artist folders. Music transfers over if there is an existing artist folder on the e280. When I click the properties for e280 within WMP, there is a checkbox for creating the folder structure on the e280.