new ultra 64GB class 10 UHS1 possibly faulty

Hi every1

   This is my 1st time buying a sandisk card but ive come across a problem im not sure is either card or reader :frowning:

I purchased a new 64GB mobile ultra UHS1 class 10 from an online retailer and when it arrived I wanted to test it so used Crystaldiskmark and h2testw but unfortunately my old multi card reader was only showing read and writes no higher than 4MB/s, so due to the age of the reader I went and purchased a “sandisk mobilemate duo”. 

     Now heres where It gets tricky using the microsd reader and plugging it into my comp usb Im getting random problems of the card seemingly being disconnected from windows 7 when i try and use the tests and copy and paste files from windows to the card. I did manage to get 1 h2testw complete and everything was fine.

  But if i use the sd card adapter and plug it in my old card reader its fine but just at low speed :confused:

so in a nut shell:-

  1. old reader w/adapter is ok but low speed

  2. USB micro adapter directly plugged into pc is giving disconnect problems.

  3. Ive tried a transcend 16GB sdhc card in the usb micro adapter and no probs :confused: (weird)

So am i looking at a card with dodgy connections or the adapter faulty? whats your thoughts?

Yeah, I think the new ultra 64GB class 10 micro sdxc has major issues. Alot of people in singapore bought it and has problem with it. The problem ranges from being not able to detect to errors writing in it etc…

hopefully sandisk sort it out soon

Can you tell write speed for this memory card(full speed tested in mobilemate)?

first the reader you bought is not going to give you the full speed either. you need a reader that supports UHS-I. The SDDR-289 is the best USB reader. it is USB 3 as well. 

that said if the card works fine in the older reader your new reader is most likely the problem. i would return it and get a SDDR-289

also for benchmarking compressed data is used. crytal mark and H2testW use uncompressed data is i remember correctly so they will never show anything close to the advertized speed. You can use ATTO for benchmarking. 

My card is defective too. It is only after 3 times of usage. It will not write and reformat. Card will turn itself off and hiccups. I can’t believe my eyes knowing that is a Sandisk product. It has a high premium. It is worse that my no name brand memory cards to be honest. Totally disappointed! A big brand name like Sandisk, quality control is very important! You don’t chage extra for nothing! 

A normal USB 2.0 will still give around 23MB/s after all the overhead. USB 2.0 theoritical speed is 480mbps = 58.59375 MB/s. 

I bought a 32gb Sandisk Class 10 SDHC UHS-1 memory card.  I had trouble with both my external card readers but on two computers with internal card readers (a notebook and a desktop) I had no problems.  Not only were the external card readers much slower, e.g. 4 MB/S but they caused the card to show up as defective using any of various benchmarks including httestw.  Using the internal card slots the speeds were around 18 to 20 MB/S and not a single error was detected on any test including h2testw.  

I have the exact same issue, card ejecting itself when transfering files to and from it in windows 7 64bit.

My write speed was 8MB/s (until it ejects itself) which was dissapointing as my 16GB transcend non micro card writes at 16MB/s with the same card reader.

I tried reformating it in windows but it ejected before it finished, now the card is unusable, can’t read write or format in any device i’ve tried it in :frowning:

I going to send it back but the question is do I get a replacement or a different card? Was the card just faulty? or was the sdhc card reader to blame even though it works fine with other cards?  Or could it be a windows 7 64bit issue?

Don’t really fancy getting another one and have the same thing happen also don’t want another if the write speed is only 8MB/s as tranfering files to it would take ages.

I just got a RMA replacement. Guess what? Same problem! Did I just waste my time and money on this piece of shxx hardware? 

I may have the same problem with a micro sd card ultra 64gb…purchased it from Best Buy online on 8-4-12…it was working good till today when one of my app on my phone gave errors that it could not write to the sd card and the sd card was not present sometimes. I tried to copy and delete files from my pc to the card and when i put it back into my phone…the original files were still there!! It now acts like a read only sd card…it wont let me delete files or add more…and whats worse is that windows 7 says it does not detect any errors on the card. Im going to backup everything i can and format and see it that works…cant believe these cards are causing problems…:neutral_face:

Did you end up sorting up your problem, this is my fourth 64GB card i am going through, with the same problems. Cannot delete the files because they somehow are restored again. Can’t format either.

I too have the problem! Have even changed it with sandisk. had to wait around a month b4 they told me they were out world wideq(after i had to bother them). Finally got the replacement. worked in my phone out the package! put it to my pc to transfer files and there is where the problem began. it copied all the folders, but none of the fillers. now i cannot write to it nor, at present, read from it

I got my Mobile Ultra microSDXC card about two weeks ago. Everything was fine until yesterday, when it was suddenly impossible to write anything to the card (files, new file system, …). The card was only used in an internal card reader from my Sony Vaio notebook and an external card reader from Kingston.

I had the same problem about six months ago with two 32GB microSDHC cards. SanDisk seems to become a bad brand…

Same problem, impossible to format card.

I hope the replacement I’ll get from amazon will work.

Is it possible, to get from Sandisk an acknowledgement that there is a bad batch or something and facilitate return and replacement policy for impacted users ?

@aureussz wrote:

 

Is it possible, to get from Sandisk an acknowledgement that there is a bad batch or something and facilitate return and replacement policy for impacted users ?

 

Smiley

Hasn’t been so far . . .

Registered just so I could post…

Same issue here. New card, no worky…

I’m a tech and I’ve spent 10 hours attempting to reformat etc to get this resolved.

I’m seriously disappointed in SanDisk for letting this go on…

Card should have been tested before being released off the production line.

–Edit–

4 more hours banging away at this… (Figured what the heck. was just going to return it anyway)

I was finally able to “partially” format using HP USB Disk Storage Format Tool (aka failed format but was readable by Windows 7 enough to recognize there was a card and it needed formatting).

I downloaded from here: [http://files.extremeoverclocking.com/file.php?f=197](Note: watch out for all the crap advertising and fake links.) Note: watch out for all the crap advertising and fake links.

I then formatted “full not quick” to NTFS using Win7 (which also returned a failed attempt once complete) but Win7 was able to read and write to the card. Note: This took a couple hours…

Next, I then formatted to fat32 using EaseUS Partition Master 9.1.1 Home Edition

I downloaded from here: http://download.cnet.com/EaseUS-Partition-Master-Home-Edition/3000-2248_4-10863346.html

Once complete, the card was readable in Win7 and in my Samsung Galaxy S3.

I formatted the card in the Galaxy S3 for good measure.

So far so good…

Final words…

Don’t purchase anything without first doing the research for any known issues.

I keep relearning this the hard way. :stuck_out_tongue:

Still disappointed in SanDisk…

Wonder how much burn-in testing SanDisk did, or how much extended wear or accelerated life testing they did not to catch this problem as it seems pretty easy to reproduce, and it gives fairly repeatable failures…

I’ve only had the card for a few days and it seems to read/write okay up to now. However, when installing it in my Galaxy Note 2, the phone’s Device Status changes to Modified and I can no longer get OTA updates to Android. Also, the Samsung Video Hub app will no longer let me use external storage.

@joelhacker wrote:

Wonder how much burn-in testing SanDisk did, or how much extended wear or accelerated life testing they did not to catch this problem as it seems pretty easy to reproduce, and it gives fairly repeatable failures…

Manufacturers have limited QC control over Chinese factories.

I had exactly the same problem.  My card was recognized in some devices, but not others (e.g… Recognized in canon 60D, but not in canon 1000D).  This led me to think it was the firmware on the cameras/laptops I use, but it’s more simple than that.

The Sandisk card is formatted as exFAT.  All my working cards are FAT32.

All you need to do is reformat your SD card as FAT32, and hey presto.  (I’ve just done this using EasyUS Partition manager, but I’m sure there’s plenty of programs out there - oddly windows didn’t have the option…)