New Sansa+ shows Japanese signs instead of English!

Hi, I bought  new Sansa+ for my mother, she couldn’t find out how to use it so sent it to me, no wonder - it shows Japanese signs (or perhaps Chinese), instead of English. It works, I have found the radio.

I have tried downloading to firmware updater to my PC to see if that would reset to English, but think there must be something wrong with the current version of the updater, it won’t install, have tried several times also after a restart of my PC, I click run and then nothing happens – nothing at all, although my PC won’t let me delete the exe file unless I restart the PC.

Will an update of firmware give me English language on the Sansa+?

If so, any tip of where to find a better version of the firmware updater?

Any other tip would be very welcome, thanks in advance.

Kind regards,

Helene

Yes, updating the firmware would give you the opportunity to choose your preferred “language”, but there is a simpler way:

http://kb.sandisk.com/app/answers/detail/a_id/7/kw/resetting%20language

English should be the 1st, or top option. :smiley: