New Clip Zip, strange version?

I got a new Clip Zip from Amazon, and the version showed up as V01.01.21A.  It wouldn’t transfer music or books to the external chip, and acted pretty wierd trying to load stuff on the internal memory.  When I went on to the Sansa website, it showed the latest firmware version to be V01.01.20. 

I finally reset my firmware to that version, and now it all appears to be working fine.

Any ideas where the 21 version came from, and why it works fine now?

@cliffw42 wrote:

Any ideas where the 21 version came from, and why it works fine now?

A slightly different/uprgraded f/w version coming out of the factory. This happens sometimes, but doesn’t mean there will be a release here.

I have no idea why it wouldn’t work, but the .20 version does. :confounded:


I am having the same. NOw I am thinking if to go to the lover version, because I need there install rocbox and I need new botloader, I am having only from 20 version but not from 21A. HOw long could be, when Sandisc will create a new bootloader for new firmware?

Probably won’t. If you want to use Rockbox, you’ll have to use a RB-recognized version of the SanDisk firmware.

And btw, the bootloader is in Rockbox. It ‘modifies’ the SanDisk firmware with its dual-boot capabilities. SanDisk does not create or have anything to do with it.

I have a similar problem.  I bought 2 Clip Zips.  I got them because they work with Rhapsody and I sometimes use them long enough to kill the battery in one.  So I have a backup.

They have worked fine for a long time.  However, they recently stopped working fine.  Both of them at the same time.

  1.  Both have become ‘sluggish’.  One of them is far worse.  Everything I do with it involves a delay.  Connecting it to the computer might take a full minute until the computer sees it.

  2.  Both seem to no longer accept new files from Rhapsody.  I created a new playlist.  I can get the playlist folder onto the clip zip, but there is no music in it.  I have plenty of space on the player.

  3.  When syncing with Rhapsody, they never seem to finish.  I have always had an issue where during sync, it will say there are a few files left, but they never actually sync.  Now, I can see it is ‘synching’, and even see song titles transferring.  But, it never stops.  I have let it sit for 2 hours and it does not stop.  And I can’t say for certain, but I think I have seen the same songs flash by more than once.

I have used the factory settings option in the settings area.  That did not reset the player to its factory condition though, because none of my files disappeared.  I did not try the format option, because I was not sure what it did yet and I did not want to turn my player into an expensive 4 gb usb drive on accident.

I have tried doing ‘resets’, but they also don’t seem to do anything.  As near as I can tell, a ‘reset’ is actually a ‘turn it off’.  (talking about the hold power button and another button at the same time)

I have uninstalled rhapsody and reinstalled it.

I have installed the Sansa Updater.  It says that no updatable sansa product has been recognized.  Not sure if this means it does not see the clip, or if it just means that the clip is current.  Either way, my computer can see the clip while the updater says it can’t.

I have Rhapsody version

I have version 01.01.21A on both clip zips.

Apologies for hijacking your thread, but since my problem is very similar, thought it might be the same root problem and did not want to create another thread.

Thanks for any help.

You might try reapplying the most recent firmware manually–see the firmware sticky thread at the top of this forum.  Very easy to do, and this can fix firmware glitches that develop over time.

If that doesn’t help, I would transfer the content you want to keep to your computer and reformat the player under its options–this often can fix unknown issues. 

Hopefully, one or the other of the above will help–good luck!