New Clip zip stay logo at start

sorry for my bad english.

i bought clip zip. firstly i power up. when pull my 32 gb sd card, it refreshed media folders. and i waited 10 minutes. it was refreshing. and i remove card. after i try 20 seconds power off. anndd :((( it doesnt start now. stay logo at start ever.  i read all posts for clip zip. i try 20\30 seconds tip. tried 2 minutes. but nothing. i try force usb connection. again nothing. and i charged 2 days.

   please help me what can i do ?

Did you wait until the media refresh was done and turn the player off before removing the card?

no i dont remember to  first i closed player or removed card.

 please heeeelppp !! :cry:   what can i do??? sansa clip zip stay at sansa logo and doesnt continues. i tried a lot of tip.

help me please

Sounds like you might have corrupted the FAT which will require re-formatting the player. But you are going to have to get it connected to your computer first. Believe it or not, just ignoring it and leaving it alone for a time (a day or two) sometimes will allow you to do a reset (holding the power button for 20-30 secs.) and get it recognized by your computer so you can do that. I would remove the card before I attempted this. Once you get the player operating correctly again, then tackle the card. You might have to re-format this too.

i tried without sd and connecting pc. and forced it. again nothing. are there another chance? can i recovery nand and format it ??

  my card was 32 gb class 10. what can i do help mee

Did you leave it alone for a few days like I suggested?

And btw, Class 10 cards are problematic. You may find this post of interest:

i dont understand your suggest. but i try this. i connected pc until player off. after i try hard reset (20-30 secs)10-20 times (different hours) but nothing. pc doesnt recognise player memory. i can not format player.


help me plsss

Do not use micro SDHC cards higher than class 4/16GB!!
It can cause your ZIP to get stuck at startup.
I’ve experienced this with a samsung class 6/16GB card, my zip got stuck on startup zo bad i even could not get a forced conection to the pc.
The only thingh you can do on this stage is to bring it back to the shop and demand a new one, while you in your two year warranty.

I haven’t heard the issue being with the capacity of the card.  Rather, it’s the card speed:  above Class 4 speed cards sometimes have had issues with the Clips.

@dalmeden wrote:

Do not use micro SDHC cards higher than class 4/16GB!!
It can cause your ZIP to get stuck at startup.

I have been usiing a 32GB card in my Zip for some time now with absolutely no issues or hiccups at all.

I am not saying it will get stuck but there is a chance it can get stuck on startup, there is a risk.
It is not only the capacity of the card that is risky it is more the combination class/…GB.

Just use a class 4 card off any capacity (up to 32GB) and you should be safe.

Here’s what the Sandisk helpdesk (Netherlands) has to say about card issues:

It is recommended to use only ordinary standard microSD / SDHC (class 4) cards.
It is not recommended to use. Class 6 or class 10 cards. This probably will not function and we can not guarantee that this will work without problems.

It is also for the use of ordinary MP3 files recommended to use up to 16GB cards, Supporting external cards up to 32GB microSD cards is intended for FLAC or WAV files, of course these are considerably greater than MP3.

If you consider that the best quality MP3 320kb / s, please understand that a class 4 card (4MB / s) is more than enough.

Now if they know that there might be poblems with class 6 or higher cards, why don’t they warn people not to use these cards in the zip, that’s what i don’t understand.

(Translated from Dutch)


Interesting SanDisk advisory there. And what a couple of us were saying is that we have never heard of an issue with a high-capacity microSD card (e.g. a 32GB card or 64GB card) due to the larger storage capacity of the card. Rather, the issue seems to always comes down to the speed of the card–that is, above Class 4 in terms of speed.