need to recover data from u3 thumb drive

I have a u3 drive that I plugged in yesterday and after I entered my password a window came up with a button that said erase.  I ejected the drive immediately. When i plugged it in after a while it was empty.  The computer generated a different drive letter for it as well.  I need to recover the data from it.  HELPPPPPPPPPPPPPP ANYONE

it sounds like you activated the secure erase. if that is the case no data can be recovered as the erase is a secure erase. 

How can I have activated the secure erase.  I just typed my password after I plugged the drive in and immediately pulled it out.  Can the secure erase work that fast, in less than a minute for about 7GB of data?

if the drive is empty then it would seem it was erased

is there any way to recover

like i said before no the erase is a secure erase

I think the quick removal caused the FAT to get screwed up.  I  have found the PhotoRec app to be useful and free for recovering deleted files. The following link shows you how to use it and it contains a link to download it.​ep

What is a good way to recover this,I also have the same problem, I just enter my password and aveything went wrong. I really need help.

Some times it happen that due to virus your thumb drive is corrupted and your lost all data and files on it, but there are data recovery software for the recovery of data and files from such situations, go for Kernel for FAT and NTFS file recovery software for the recovery of your files and data from thumb drive, it has an user friendly interface through which you can preview your data in scan mode and then you have the choice to save all or some selective files to your location. for more details go to -

You forgot to mention that the app you recommend is $30.  :dizzy_face:

I have also the same problem,Is there any way I can recover my files?Thanks.

At this point probably not.  Sorry mate.

I used the Kernel File Data Recovery application.  It seems to work.  I have recovered a bunch of 2048 MB clusters however they are encrypted.  Also all the clusters are the same and I don’t know how to put them together.  Does anyone know how to put the files together or how to decrypt the files?

As you have found, recovering clusters is not the same as recovering files.  You have two choices; 1. write to the vendor of Kernel File Data Recovery application and ask them for help in using it or 2. use one of the recovery apps suggested here.

I tried photorec and the other product on their site and did not work. however the second product worked but did not save files only clusters.

This happened to me once and I have learned something from it. Don’t speed things up. Try to slow down on working with your files especially on important ones. If everything else fails, always think that ‘you should not get yourself too attached to things, learned to let go’. That is, if you can’t do anything about it anymore.

My thumb disk worked fine this morning.  Now I plug it in and it doesn’t light up and nothing shows up on my computer that it’s connected.  It’s warm to the touch.  Need something that was saved on it.  know better now to save it in more than one place, but how do I get the info off it???

a. Let it cool down.

b. Try a different USB port.

c. Try a different pc.


Tried all that and still nothing

u3 data recovery