U3 Removal Tool Windows XP

My Cruzer Contour recently got corrupted from trying to run U3 in a Windoiws 7 machine. The flash drive dismount because of this and I decided to use the U3 removal tool on an xp machine. i clicked on the item which asked if I wanted to restore after the process. However, when the process was done there was no data restored and it just indicated that the process was finished. Some of the items there have no bacjkups since they were made during the time the u3 device partition was corrupted.

Is there anyway to recover the data via a cached   file in Windows or anything?

Try the recovery apps shown in the bottom posting of this thread: http://forums.sandisk.com/t5/All-SanDisk-USB-Flash-Drives/repair-files-after-removing-cruzer-edge-USB-from-computer-during/m-p/232036#M966

Normally the removal of U3 does a Quick Format which doesn’t actually erase the data just the FAT. You may be able to recover some files if you haven’t written to the USB drive since this happened. 


I tried this but the only files I could recover were somehow related to the u3 installation files root folder. I could not recover my sub folders such as documents and such. I am honestly irritated that they would offer a restore option that does nothing at all.

Having never removed U3 I can’t speak from experience on it’s pros and cons but if the user files were lost when you tried the device in a Windows 7 machine the U3 removable process can’t magically find them to back them up then restore them.  They were already gone. 

I suspect the USB device wasn’t Safely Removed from the Win 7 machine which screwed up the writable partition’s File Allocation Table.

BTW and FWIW I was able to run my U3 device on Win 7 32-bit machines no problem but struggled with it on Win 7 64-bit machines until I found running it in Vista Compatibility Mode worked.

It wasn’t U3 was trying to install itself in the Windows 7 from the drive which is an obsolete version that SanDisk claims is obsolete and incompatible. The files were then lost after the failed to launch u3 pop up and the device was not recognized forcing me to use the uninstaler I mentioned. After using your suggested link, all that was left was document files of U3 applications such as the free games and the password vault thing. 

In that Win 7 and current versions of Win XP do not autorun things on removable drives how did U3 start?  If the drive wasn’t password protected the files on the writable portion of the device were accessable without invoking U3. 

Should you ever encounter a similar situation in the future I recommend you use the Win 7 Safely Remove option to remove the drive rather than using the uninstaller on the unrecognized drive. 

hmmm if the drive was not recognized how were you able to run something on it?

I safely removed the device but inserting it after automatically dismounts the drive because U3 couldn’t launch.

Windows won’t dismount a drive because something won’t run.  An antivirus app will do that though.