Need some serious help. (Cruzer Orbit)

Ok. so I bought a cruzer orbit 32gb yesterday.
I pluged it into my computer and for the first time it was perfect.
I put in all the files I need onto the drive then have it unpluged.
plugged it back into the computer at night and the drive cant be regonized for 3 mins.
3 mins later the drive shows up and its empty. Not 0 / 32gb empty…but   0mb / 0 mb kind of empty.
so I did some researh…went to device manager, have the orbit’s driver uninstalled.
unplug then plug it back in, the flash drive immediately started to work again…
I thought…wooo…I fixed it.
but nope!!
The next unplug&plug did the same thing again. Which means I have to uninstall the driver everytime if I want to use it.
At first I thought it was my computer thats causing it. I have 3 other usbs laying around and none of them caused any problem.
hmm…so I thought…may be its the Orbit’s problem? brought it back to the store have it exchanged for a new one.
and the same thing happens…sigh…
I tried it on another computer the orbit was working perfectly fine…
so … basically this is happeneing only on my computer with only curzer orbit…

I am running

CPU: i7 920,

Ram:12GB
OS: Win7 64bit

HELP!!!

This is a hardware issue. Since this is new, I’d suggest to check the warranty here. Perhaps you can ask for a replacement at the store you purchased this from.

In that the problem only occurs on your pc I doubt it’s a problem with the Orbit. 

Is the Orbit configured for Quick Removal or Better Performance on your pc.  If the latter, not using the Windows Safely Remove function when removing the Orbit will corrupt its FAT which may explain what you’re seeing.