my Sansa Express is dead !

Dear All,

Can anyone help me in activating sansaExpress again ? …I did use it for Documents as well …hope should be an any issue…

thanks in advance.



I just registered on this forum myself and have not had any issues with my Express dying on me.  However, I do know that you’ll have to provide a lot more details than what you gave.  What were you doing just before it died?  Could it be a completely dead battery?  Do you get anything when you plug it into a USB port?  Have you tried a soft reset (Main select button + volume up button at the same time)?  Were you adding or deleting files just before it died?  If so were you using MSC (USB mass storage) or MTP (Window Media Player) when it died?  

There is no hope that anyone can help you with out more details.  Also be sure to browse around all the exiting forum threads and try some of the tricks listed on those other threads.

A friend of mine had a problem that sounds like yours (hard to say for certain without some more details) and he got it fixed by calling or emailing SanDisk. After he described his issue, they sent him a fix.

EDIT: I forgot Poland.  This should take care of it quite nicely:

Message Edited by kennyj on 12-24-2007 12:00 PM

look for my post (message no:42) in here :

m…i tried everything …nothing works !

completely dead…all of a sudden…not recognised by the computer anymore …

nuthin zip…'n am prtty sure its got full battery… :cry:

pleeeeeeeez help

San disk: Express 1GB