My Sansa e260

Recently, i deleted all mu music file from the folder…and since my gadget hung-up once in a while…i RESET the system…and the next thing when i switch ON my mp3…it went black blank and it say a small icon " LOAD MAIN IMAGE FAILED, SWITCH TO RECOVERY MODE "…

Please, somebody help me coz im empty handed with this…my mp3 stay for me about 5years now and i lost the driver…can anybody help me out? 


You need to manually re-install the firmware:

Don’t click the link for the Sansa Updater. Instead click the link for the version of firmware appropriate to your geographical location and floow the manual installation directions.

Thanks Mr. Guru for the guide…the problem also i forgot to tell you that…my mp3 Sansa e260. does not detect my Computer…even i go to my " Devices" , is not in highlight status… When i plug my mp3 to my computer ( Netbook ), it only light up my device and in the MP3 screen say … " Load main image failed switch to Recovery mode "… How i can dod that? …can i have guide why  my mp3 doesnt detect to my computer? …Glad to go through with this…Thanks in advance.

Are you able to connect in Recovery Mode? Move he HOLD switch on top of the device to ON (towards the headphone jack), hold the REC button on the side and plug into the computer, continuing to hold the REC button until it is recognized.

Then this post sholld help you with the rest:

Thanks for nice info flow Tapeworm Guru, now i manage to see the display now in my e260, both ways…the problem now o download some music on it  ( MSC mode )…and i cant play with it , say’s  “NO songs” , its empty , but in the properties its consuming the data space about 1G.

I plug out the e260 and change to MTP, the files is also there and even my OLD song i deleted before i did the reseting before it went blanck…i tried to delete my OLD song in the folder , but doesnt work or delete at all…something i missed on it? … Please help me trough this course coz im dired with it … Thanks again Tapeworm Guru

@shaj1030 wrote:

now i manage to see the display now in my e260, both ways…the problem now o download some music on it  ( MSC mode )…and i cant play with it , say’s  “NO songs” , its empty , but in the properties its consuming the data space about 1G.



This could be an ID3 tag issue. Scroll down the Artist list on your player and see if you have an “Unknown” entry. Select it and see if your missing music is there. If so, the player cannot read the ID3 tags of the files. You will have to correct and/or edit them so it can. MP3Tag is great for this.

In my e260…its EMPTY all the list…all i can see when i connect to my computer , all my files which i dowloaded…what is Mp3tag? … ill download one of the formats?

Try resetting it by holding the powere button for +/- 30 seconds. Release, then press the power button again to start it up. Does you music now show?

MP3Tag is a free, dedicated ID3 tag editing program that is highly recommended for anyone with an mp3 player.

Well, i do it with your instruction and still doesnt work or show any music files i dowloaded…it shows Empty… by the way my e260 version is 01.02.24P.

I want to delete also the files i downloaded…but it well not work or i cannot delete anymore…what can i do?

You can format it. But that will erase everything you’ve put on it. Is that what you want?

Good day Tapeworm Guru,been since i was dire to correct this…i just do the FORMAT thing,and all the date now is gone…what all i do next?

By the way, what is the possible safe way to download music in e260…MSC or MTP…i just hope with this time well be done, coz you’re stack in my silliness =( … Hope you can guide me through.

Tapeworm Guru…i just did my deed of " FORMATTING" …now i lost all the data from my mp3…how or what next ill do? …im in vain with this and hope you can guide me through with it…again.

By the way what posibble good for downloading Music file from my computer to my e260…MSC or MTP mode.

Now that it is formatted and the memory cleared, you can re-transfer your music to it. It is easiest to use MSC mode and just drag & drop (or copy & paste) the files from your computer to the player.

You only need MTP mode if you use Rhapsody or some other subscription service.

Kudos to you Tapeworm Guru…now its back and working again =) … im still Jurassic in this digital world. Everything is working good and back to normal and i can come back too =) …

I never regret to choose all my Sansa Stuff, from Mp3 to my Hard drives, Memory SD  to all products of this…Thank you for guiding me trough this course…and this forum is awesome as wonderful, God Bless.

Glad things worked out for you and you can enjoy your player again! May you have a blessed day as well. :smiley:

I had the same trouble (full playlist shows when contected to my pc, but won’t show and can’t access through e260 player).

I ended up reformatting the player to wipe everything.  Now I just tried to drag and drop 1 podcast onto it.  Now the player shows as ‘writing’ but it doesn`t seem to stop writing.

Any suggestions?