my san disk cruzer disconnects immedietly after being connected

what the title says :slight_smile:

i tried the chat support and had a lovely conversation with the guy there

Hello, thank you for contacting SanDisk. My name is Brian Singh. Please give me a moment while I look into your question.
Brian Singh: In order to help you, please provide the 2 Alphanumeric product codes located on the back of the drive and the color of the drive to determine which SanDisk product you have.
Mohamed Zaki: the fist code is SDCZ36-016g
Mohamed Zaki: second is : BL1003ODKB
Mohamed Zaki: it’s black with an orange led
Brian Singh: Thank you.
Brian Singh: Please tell me from where and when did you purchase it?
Mohamed Zaki: from a local store in egypt, 10/2010
Brian Singh: Are you contacting us from Egypt?
Mohamed Zaki: yes
Brian Singh: You have reached the chat technical support for US and Canadian customers, so I request you to please contact your nearest region Please refer to the link to find your nearest region: http://www.sandisk.com/sandisk-support/contact-us
Brian Singh: Is there anything else I may assist you with, Mohamed?
Mohamed Zaki: is there a possibility u can just help me with this problem ?
Brian Singh: Mohamed, we have the dedicated support for Egypt customers, so I request you to please contact your nearest regional technical support.
Mohamed Zaki: there is no dedicated support for egypt
Mohamed Zaki: nearest is saudia arabia
Mohamed Zaki: and i don’t see a chat option
Mohamed Zaki: i have to send a ticke
Mohamed Zaki: *ticket
Mohamed Zaki: also the chat queue is pretty empty so am not taking anyone’s place or anything
Mohamed Zaki: i don’t think my problem would take long
Mohamed Zaki: can u help me ?
Brian Singh: Mohamed, there is no chat support for Saudi arabia, for assistance you need to call at there number.
Mohamed Zaki: i currently can’t make an international call
Brian Singh: Mohamed, you have contacted the chat technical support for US and Canadian customers, so I request you to please contact your nearest region.
Mohamed Zaki: thanks
Mohamed Zaki: bye
’Mohamed Zaki’ disconnected (‘Concluded by End-user’).

even though i entered through the international support portal

so i came here for help, thanks in advance

I have the exact same problem. The usb connects, the icon is shown but it disapperas right away. I tried connectin on other computers both windows and Linux but to no avail. Same thing. Is there any workaround?

I would have thought a weak power supply but you said the same thing happens on other pcs so I’m at a lost.  Maybe the electrical contacts are oxidized or maybe it’s defective.  Return it to where you bought it or to SanDisk directly.

My 32Gb has just started doing this today after a goodly amount of trouble free time. Item is a 32Gb of stored data and never written to…

I want access to the data - not a refund!

error shows as:

Cruzer insert/access error W7

:smiley:   Hi Hieroglyph,

Dear member of SanDisk Community, welcome.

Please, you can test your Cruzer, in other PCs, to define the problem.

Excuse me the hassle you, but then I have, any more information for review, and not run the risk (for you), to guess what happens.

Thanks.

Regards, Alfred.                                                            (Google translated)

/\ It does same on another W7 and XP laptop… it tries to load as portable device  (along with non existent CD ROM J??) but gets kicked out - see screenshot before getting kicked out… It did always have drive K:/ allocated…

loading sequence screengrab

With the CD drive it sounds like a U3 Cruzer. 

Getting disconnected immediately would sound like a antivirus security problem but you said it happens on multiple machines so unless all the machines have the same AV I don’t think that is the problem.

So we are left with a problem with the Cruzer. 

If it is shorted out there isn’t much you can do, unless it’s a dead spider in which case clear it out with a toothpick. 

If the problem is oxidized USB contacts you can possibly clean them lightly with emory paper

:smiley: Hi Hieroglyph,

My 32Gb has just started doing this today… ]

Well, in the second picture, I see you have installed Nokia phone.

-With another Pendrive, is the same problem?

-The problem started after you installed it?

-You also have this program or similar in the other two PCs?

Then see, in the Task Manager, the processes which are running, and see what are the necessary and what to delete.

Because, there are some services programs, telephones and video cameras, that cause system conflicts, by interference in USB ports, such as: Samsung Kies, HTC Sync, Sony Play Memories, Motorola, etc.

Luck.

Regards, Alfred.                                                                                (Google translated)

Same thing happening to me, it starts yesterday, I tried inserting the Cruzer in computers with XP and W7 and the same issue is happened.  It connects and after few seconds it disconnect again.  Any clues?

:smiley:   Hi Chemy468,

Dear member of SanDisk Community, welcome.

[Any clues?]

Yes, precisely in previous post to yours.

Luck, and then you tell us, what happened, please.

Regards, Alfred. (                                                          Google translated)

:smiley:   Hi Chemy468,

Dear member of SanDisk Community, welcome.

[  Any clues? ]

Yes, precisely in previous post to yours.

Luck, and then you tell us, what happened, please.

Regards, Alfred.                                                             (Google translated)

I spotted a possible recovery remedy on youtube but it is destructive and renders the drive useless for normal use after:

https://www.youtube.com/watch?v=ldC06C28SXQ