My "ALBUMS" folder doesn't show up when I connect to the computer.

When I first got it there was an “ALBUMS” folder and a “MUSIC” folder. I put all my music in the “ALBUMS” folder, but now I can’t access that folder when connected to the computer. Is there anything I can do, short of deleting all the music using the Sansa menu itself and instead placing it all into the “MUSIC” folder?

Sounds like you might have switched USB modes.  I’m guessing the player was originally in MTP mode and has been switched to MSC.  Try setting it to MTP.

The thing to remember:  files transferred to your Clip while connected to your computer in MSC mode only show on your computer when you are connected in MSC mode.  Likewise for MTP mode.  The reason I find it best to try to use one mode consistently (I default to MSC mode, as it’s more universal and I don’t need MTP mode for protected files).

Yes, before I had it set to auto-detect, but after I reformated my computer I had to switch it to MSC to get the Sansa to be recognized at all. Is there a way to get it recognized through MTP mode again?

@gavingt wrote:
Yes, before I had it set to auto-detect, but after I reformated my computer I had to switch it to MSC to get the Sansa to be recognized at all. Is there a way to get it recognized through MTP mode again?

Try checking it out in Device Manager. If there’s a little yellow warning triangle then you’ve found your problem. Dis-enable or delete the device, un-plug it and re-boot your computer. Plug your player back in (in MTP mode) and Windows should now see it as ‘new hardware’ and locate and load up the appropriate drivers for it.

@gavingt wrote:
Yes, before I had it set to auto-detect, but after I reformated my computer I had to switch it to MSC to get the Sansa to be recognized at all. Is there a way to get it recognized through MTP mode again?

Since you reformatted your computer, maybe you need to install an updated WMP?  The needed MTP support files are included with WMP 10 or 11, they aren’t actually included with Windows itself.

Better yet, ditch MTP if you don’t need DRM support.