Music Folder is EMPTY on Sansa C250 in My Computer--music is on the player

I have a Version 1 Sansa C250 that I loaded with music last year. Now I want to change some of that music and when I look at the Music folder in My Computer, it is empty.  Properties says O bytes.  Yet, I can go on the player and access all the music.  I know there is something about changing from MTP to MSC mode but I believe on the Version 1 players, you can’t change this.  Besides, I used this same computer to load the music so why doesn’t it see it now?  I did, however, have to reload Windows over the course of the year if that makes some kind of difference.  Can anyone tell me how to access the music files through the computer so that I can delete them?  Also, I tried deleting the Music Folder and then creating a new one.  Didn’t make a difference.  I can also load new music into the Music folder and it does show up so there is something different about the older MP3 files.  How do I see them?  Thanks.

1.) Your computer cannot ‘see’ files unless the player is connected in the same USB mode as when they were transferred.

2.) Yes Virginia, you can change from MTP to MSC mode on the e200v1 machines. It’s in Settings > USB Mode.

3.) If your player was (or is) set to Auto Detect, it can (and will) connect in either mode. It will default to MTP, but if connection is not possible, it will connect in MSC. This may be what has happened in your case, especially if you’ve re-installed Windows. MTP mode needs drivers found in Windows Media Player 10 & above. If you’ve got WMP 9 (as what came bundled with XP) you may need to update to 10 in order for MTP mode to work.

4.) Another little wonky thing with the v1 players is that the Music folder is ‘hidden’ when connected in MSC mode. You have to change the settings (in Windows Explorer) to “show hidden files and folders”. This is probably just FYI though; I don’t think this is your problem since you can see your Music folder (albeit empty).

5.) When you open Explorer (My Computer) with your player connected, how is it represented? If it’s shown under Devices With Removable Storage alongside your other CD drives, etc. and is shown as 2 new and separate drives with their own letter designations ( like J: & G: ), then you are connected in MSC mode. The 1st drive letter will be your player; the 2nd one is the card slot (whether there’s a card inserted or not). If your player comes up under Other and is named Sansa e200 series (or similar) and only has 1 icon, then you’re in MTP mode.

I am having this Problem As well. However , it is only with one song that I have on there.If I Search my Device , the Song does Not come up ( manually searching through, OR with Windows search.) 1.oh? Maybe the One Song I have Not showing up anywhere on my Computer ( only in my sansa in the Music Icon ) can Be Found if I connect it to the Other Mode ( Auto- detect? ) 2.No. Not on Mine. I only have “Auto-detect” und MSC modes . On my e280R , I had MTP & MSC both. 3. Interesting. This is what Auto-detect Mode is? Soo , it is MTP, ja? 4.Not hidden… 5. I always connect in MSC mode. BUT , maybe just once I had it connected in MTP Mode. I will try Auto-detect, und See if I can find the Song now.


I have a new computer, my old one died and I lost all my music. How do I bring music to my computer, from my sansa.

Appreciate any help

thank you 

  1. Open Windows Explorer.
  2. Navigate to the Music folder on you player.
  3. Highlight all in that folder (Edit > Select All).
  4. Go back to Edit. Select Move To Folder… or Copy to Folder…
  5. Navigate to your My Music folder on your computer (or wherever you wan to store the files).
  6. Click the Move or Copy button.
  7. To transfer them back to a new device, just reverse the process.