My 5 months Fuze can't charge anymore

I got it 5 months ago. It worked fine till last week I couldn’t charge it when I connected to my laptop it said connected and charged for a while then it stopped charging but stayed connect ,my laptop can’t see the Fuze. Also I charged it directly still can’t. I have checked the cable with the other sansa it works fine so the problem is not cable. I charged it with wall charger it didn’t work.

Could y’all give me some suggestions,please?

Thanks for your help 


Try charging it with a USB wall charger. If that doesn’t work, then send it to Sandisk for replacement. The warranty is for a year.

Did you recently update the firmware or format it? The USB mode might have gotten changed affecting the way it connects. MSC mode is the easiest to connect in.

Also, is your laptop plugged into AC power? Have you tried a different USB port or a desktop computer?

If none of these suggestions help and you say you’ve already tried an AC wall charger without success, it might be time for a call to SanDisk for a potential warranty replacement.

yesi did try but it didn’t work 

Oh Yes my fuze returns now thanks for both. I formated it 2 times and it  works thank you so much.