Music that is on my Clip doesn't show up on my computer.

I love my Clip, but I’m having some trouble with it.

I’m trying to delete the muisc off of my Clip and put different music onto it, but the music that has been on my Clip doesn’t seem to exist, according to my computer. When I plug my Clip into my computer and open Rhapsody, or even the Clip itself up (through My Computer, then drive L: SANSA CLIP) I can’t find any of the music on it. I’ve enabled Hidden Files, and this is what I see:

All of those folders are empty, save for RECORD, which has an empty FM and an empty VOICE folder in it.

Yet the music is still on my Clip. I can unplug it from my computer and listen to it (and no, it’s not the radio).

How can I find this music and get it off, so I can put new music on it, or am I stuck with the same songs forever?

you are connecting in MSC mode and you probably copied the files over in MTP mode.  go to settings > usb mode > and select MTP. you should then be able to see your music when you connect it to the computer. 

That fixed it! Hey, what do these different modes do? Which one should I keep my Clip in, or does it matter?

I have the exact problem on mine.  However, when I set in MTP mode, Windows displays the install driver wizard.  If I cancel out of that, the clip doesn’t appear in Win Explorer.


  • a -

Update:  I resolved this one by installing Windows Media Player 11 and setting the SansaClip in MTP mode

  • a -

@ajaxoftherockie wrote:

Update:  I resolved this one by installing Windows Media Player 11 and setting the SansaClip in MTP mode


  • a -

You can still use WMP in MSC mode. To solve the invisible music problem just requires using either MTP or MSC…auto-defect is where the probles start developing with hidden songs. :wink:

The issue is:  files put on your Clip when your Clip is connected to your computer in USB MSC mode are only visible on your computer when your Clip is connected to the computer in MSC mode; likewise as to MTP mode.  And if the Clip’s USB mode is set to auto, the Clip tries to connect in MTP mode but then will default to MSC mode.  Which all can result in confusion.

Hence, many people will set the Clip’s USB mode to MSC or to MTP, for consistency (and to be able to see all one’s music at one time).  MSC mode is more universal, and will work on more computers, including Macs and with Linux.  But MTP mode is needed for DRM’ed files.

my pc can’t find my sandisk .ithink i was hanged .istore music in it and now it does not work. it stopped at first page sandisk…what can i do?

Can you reformat your player under its settings?  Note:  this will erase your content on the player.

First, you might try a reset of your Clip, in case that helps.  And can you try to force a connection to the PC, by turning the player off, putting it on hold, and then connecting via USB while holding the center button down?

This is the same case for my sansa fuze 8gb player. How you can read it on a mac is by using the android file transfer program which allows you to connect via mtp - which you have to select in the fuze’s system settings under USB.