MTP Device Problem

Just got the Sansa Connect without the Wifi but if I plug it into my pc (Win XP SP3) it only sees it as MTP Device. I searched this forum and found some anwsers to it. I reinstalled WMP11 (+some hotfix), I did go to control panel->system->hardware->device manager->portable device->delete mtp device and then rebooted my pc. For like one second after reboot my pc saw it as Sansa PMP but switched than again to MTP advice.

Can someone help me?

The Connect IS an MTP device … why is this a problem?

If i plug it in to my pc the only message i get is “New Hardware found - MTP Device” (or something similair, i have a Dutch XP version) but nothing else seems to change. I won’t find the Connect in my Explorer or so

Have you been able to use a different MP3 player on your PC via MTP?  If you haven’t already, you may want to try re-installing Windows Media Player.

Yes i used other MTP Players before but they don’t seem to work anymore either (they did worked always worked fine) and yes I re-installed WMP 11

Bad USB port?  Bad USB cable?  You could try using the same cable to connect it to a different computer, etc.  Does any USB device work on your PC?  Have you tried other players in MSC mode?

USB ports and cables are fine and MSC players work too

Message Edited by TimD on 05-18-2009 12:03 PM

Sounds like you’ve got a problem with your MTP installation, then.  Usually reinstalling WMP takes care of this problem.  I don’t really have anything else to suggest other than that if you’re running XP, and this problem started happening fairly recently, you may want to do a System Restore to a date before the problem started happening.

One thing that’s worked for many connection problems, where the computer sees the player but doesn’t fully and properly recognized it, is to fully turn off the Connect before attaching it to USB.  I.e., with the Connect turned on, hold down the Power button for at least 8 seconds (the displayed message changes from something like “Sleeping” to “Shutting Down”–I don’t recall exactly the words–and then the screen goes black).  Then plug the Connect into to the PC, and patiently wait a while (the player will slowly display all 5 balls, and a while later it will get recognized).

Actually, one thing I’ve noticed is that when I have my full (2880 MP3s) 16GB microSDHC card inserted in the player, MTP won’t recognize it, even when using jj2me’s method.  I need to take the card out, shutdown the player, connect it, turn on the player, then put the card back in.