MP3 Audiobook files out of order on Fuze

I make sure the files are in the right order before sync hing them to the fuze. When I check them on the fuze the order is changed. This is bad because the audiobook files must be played in order.

I have checked the tags, they are perfect.

Why would the fuze change the order of files synced with WMP or Mediamonkey? I even tried dragging the files directly to the fuze in explorer, they are still out of order.

Amber

Try this (I have only done 1 audiobook and it was on a clip so Im guessing a little) go to the audiobook and play the first chapter, then hit the menu button (6 o’clock on the wheel) and find where it says Chapter mode, then make sure this is on. It helped on the clip.

I believe that setting is to allow you to use the forward and back buttons to move to the next and previous tracks.

How many files are there?

I made the initial mistake of numbering my mp3 audio files as 1,2,3, instead of 01,02,03 etc with the result that I ended up playing 1,10,11 etc.

If I wasn’t extremely careful to control-A to give all files the same album name, same artist etc they could end up in the “wrong” order - not sure what order the Fuze uses for choosing the sequence of tag “fields” (to use database terms).

I now make life easy for myself and forget about tagging - I create a folder e.g DiscworldTruth on my pc, give the files simple names such as Truth01,Truth02…Truth22, then drag the folder to my fuze in MSC mode. I can then just go to the folder view in the latest firmware to call up whichever book/play to which I want to listen.

It is simple, it works. I know what I am listening to without needing lots of text on the screen (which switches off anyway to save batterypower after 15 seconds) so tagging to me is extra effort for no benefit.

Thank you Sansa techies for providing the folder feature.

exegnomad: Folderview is fine, but you lose the bookmarking feature of the Audiobook folder, right??? This feature is very helpful if you want to listen to other music and then come back to your book.  Try as I may, I can never remember the disk and track number without that audiobook bookmark.

I’m having an audiobook track order issue too… this is really annoying. With more than one book I’ve been able to go to the Audiobooks folder, see the titles of the books, move to the next screen where it automatically highlighted the last listened to track and then starting that track it asks to Resume or start Fresh.  This *was* fantastic! However it seem to get lost somehow…

With my recent books, my audiobook tracks seem to be ordering by track number only then random beyond that! This is highly annoying and makes listening to them nearly impossible.

I believe I’m using the same filenaming and tagging schemes at prior books.  I even went crazy with it: I have filenames AND titles both prefixed with dd-tt where dd is the two digit CD number and tt is the two digit track number.   I have all the files separated into folders by disk number.  Those folders are all in a folder with the book title as the name.  All the album titles on all the tracks are exactly the same.  Still they’re only ordered by track number on the Fuze!

This happened before getting the latest firmware (I think I was using 1.2.17) and still happens with the latest.

Can anyone else report similar issues? Either that or suggest a working method for getting a book to show in the Audiobooks section, by book title (without seeing all the separate CD’s)?

Is bookmarking possible with the latest firmware? People were complaining about the lack of it in the previous version  e.g.

 http://forums.sandisk.com/sansa/board/message?board.id=sansafuse&message.id=17728&query.id=375274#M17728

I must admit I’m still finding my way round the features - the user guide seems to leave out an awful lot of practical information.

The only time I have used the resume feature was on a novel in the Audible folder. For material in audiobooks that I have ripped or downloaded from broadcasts I have used Slice from NCH to chop material into chunks of about 10-12 minutes which means I can usually find a convenient place at which to stop.

I’ve formatted after updating so lost the previous files so can’t check back all details, but had three BBC dramatisations of Jane Austen novels, which under audiobooks were arranged as all the chapter ones, then the twos etc. I didn’t bother listening to them, which would have been a novel experience in a different meaning of the word!

On another occasion using Windows Media Player I put tracks I had ripped from c.d.s into a playlist, and noticed that WMP immediately changed the running order, but I couldn’t spot the logic behind the out-of-order sequence.

As for getting book titles to show in the audiobooks section, mine is showing the titles of three books from cd,three from radio broadcasts and a subsection for audible which contains two books.Opening the folder for the book then gives access to the “chapter” files.  As far as I know I haven’t done anything special, I just dragged them as folders from my pc.

If it makes any difference I have a version 1 black 8gb fuze with 4gb cards, bought from a French company operating in the UK.

exegnomad, thanks for the additional comments.

Some general comments in the interest of just establishing facts (hopefully which are true!):

By bookmarking, I’m talking that “Resume” feature on Audiobooks… I know *it* was available on at least the last two firmware updates.  I have only owned my player for a month or so so I can’t say before that. 

I *do* know that this feature was not on the Fuze when I purchased it – so it was a welcome addition.  (I do, however, agree with the author of the post you link to – I think supporting multiple bookmarks would be extremely helpful.  And this Resume is far from perfect.  After adding more music to my player one time, the Fuze somehow lost the “bookmark” to the book I was currently reading.  I like the description of bookmarking in that linked post.  It could be just another entry like Playlists under Music.  And like bookmarks in a web browser, selecting one would take you directly into that book.  Hmm… as a software developer myself, I wonder what “that book” means… all tracks with the same Album title in the Audiobooks folder? )

I *did* get some Windows updates earlier this week.  I’ll admit… I like to blame Microsoft for other stuff, who knows, maybe somehow some update to IE or WMP affected this functionality.

More on my process of tagging: 

  • My track titles do use the leading zeros.  

  • Both wma and mp3 files did at one point have this Resume functionality working on my Fuze.

  • I do the drag files/folders method to add music, etc.  My audio books are tagged with “Audiobook” for the genre and dropped in the Audiobooks folder.

  • My Fuze is a 4 GB device and I currently do not have a card in it (but one sits on my desk waiting to be opened.)

More investigation/observations:

  • Took the first three tracks from two CD’s (from an Audiobook) and tagged them all as track 1.  The Fuze seemed to sort either by Track Title or File Name.  I’m not sure which because they’re both the same.

  • Tagging all six files with consecutive track numbers (1-6) ordered them in the correct order.  (So there’s a possible work around here, but I’d really prefer to keep my files in separate folders by CD and numbered by track on the CD.)

  • Tagging them as CD 1, track 1, 2, 3, and then CD 2, track 1, 2, 3 put them in the order CD1 track 1, CD2 track 1, CD1 track 2, CD2 track 2, CD1 track 3, CD2 track 3.  This really doesn’t work when trying to listen to audio books!

I may have stumbled on an answer.

I have a 4 CD set audiobook, converted it to mp3s, copied it to my Fuze in MTP and MSC, and it played in unusual order. I believe it played track 1 then track 1 etc. for all CDs, then went to track 2 then track 2 etc. for all CDs. Therefore I numbered CD2s tracks successive to CD1s tracks and continued numerically thru the 4th CD. All other tags seemed to have no bearing, and an m3u list did not help. But with all tracks numerically increasing in value it seems to be corrected. I’ll listen to the whole story next to verify my answer is in fact correct.

Yes, this is pretty much what I did in the second bullet of my prior post.  I guess mine were all in one folder where yours sound like they’re in separate ones.

I’d really prefer to have them in separate folders, tracks ordered by each CD, rather than tracks ordered over the entire book.  It seems like an obvious firmware fix here is to have the CD tag recognized.  Your suggestion does seem like a work around that will at least make the tracks playable.

Now… my current book is 26 discs! Any suggestions for tagging software that will consecutively retag all those even if they’re in separate folders.  I currently use EasyTag which is pretty nice.  It, however, will automatically restart track numbering on  each folder.

The disc number ID3 field is not used by the fuze?

I had file order issues when I had tagged my tracks with a ‘/’ in them, like 01/45, 02/45 etc. 

I prefer to have all files of an album in one dir (not seperate CD dirs), so I tag them accordingly as 0101 (for CD 1, track 1), 0102 etc. Having the tracks play in the right order is more important to me with audiobooks than having the files neatly organised in dirs per CD.

7o9’s method should work when there are only a couple of ripped cd’s, but it will take a fair bit of editing with a long book spread over several discs.

 As for Porwah’s 26 disc book, I don’t fancy his having an awfully long session typing in the new numbers.

Is there any software that would allow us to increase the track numbers of all the files in a directory by a chosen amount e.g if disc one has 15 files add 15 to all the track numbers of disc two.

@7o9 wrote:

The disc number ID3 field is not used by the fuze?

 

I had file order issues when I had tagged my tracks with a ‘/’ in them, like 01/45, 02/45 etc. 

 

I prefer to have all files of an album in one dir (not seperate CD dirs), so I tag them accordingly as 0101 (for CD 1, track 1), 0102 etc. Having the tracks play in the right order is more important to me with audiobooks than having the files neatly organised in dirs per CD.

I believe your problem with not playing in the correct order before may be because the Track and Disc# ID3 tags are not supposed to have leading zeroes in the numbers. You only have to do that for the actual computer file name so that they show up in the correct order when using Folder/file view.

Also, technically track numbers should never be larger than 99, but as you’ve seen the Fuze doesn’t seem to care if the numbers are larger.

As for the Fuze using the Disc number ID3 tag, I think it can (if that tag is there). I have one set of files for 2 discs that is tagged like this and it seems to play in the proper order:

Track#   Disc#

  1/6       1/2

  2/6       1/2

  3/6       1/2

  4/6       1/2

  5/6       1/2

  6/6       1/2

  1/7       2/2

  2/7       2/2

  3/7       2/2

  4/7       2/2

  5/7       2/2

  6/7       2/2

  7/7       2/2

Notice that the track number for the 2nd disc starts over at 1. It would not be logical to have a disc that starts with a track number greater than one (that could really mess up some burning programs).

For an audiobook, the ID3 Title tags for the above would be something like Chapter 1, Chapter 2, on up thru Chapter 13. And, of course,  the Album Title tag would be the name of the book.

On the now playing screen the Fuze will show things as being 1/13 on up to 13/13. That’s because on that screen it’s showing which file of the full set it is currently playing. So, don’t be confused by that.

However, the newly added feature to view the current track playing info does not display a slash between numbers like it should do. For example, instead of showing track 1/7 it will display it as 17. And the disc number, instead of 1/2 will display as 12. Hopefully they’ll fix that minor bug in a future firmware update.

I’m not sure if what I posted above helps any or if it will just confuse some people even more. All I know is that if the ID3 tags are done properly things do play in the correct order for me. As they say “your milage may very”.:wink:

[Edited to add audiobook details]

Message Edited by miltst on 04-23-2009 07:59 AM

Hello,

I’m not an expert but this is how I got a 20 disc bible set on my fuze. I am still using the previous firmware, as the most recent gave me some issues I didn’t like.

I used Window Media Player and MTP mode.

First I copied all the cd’s into mp3 using wmp.

I then tagged the files  like this. I went to each chapter right clicked and went to advance tag editor.

Title: the actual name of the bible chapter (example: Genesis chapter 1) 

Genre: Audiobook

Track: 1, 2, 3 …

Album: Word of promise

Original Album: The word of promise

Set number: 01, 02, 03 …

On the next tab over I put the following:

Album Artist: Word of promise

Composer: The bible

When you look at the album in WMP. the chapter numbers look like 1, 1, 1, 1, then 2, 2, 2, 2,

I then used the syc feature and put it on my fuze.

Now I can go to the audiobook section and the album “Word of promise” is there. The chapters underneath are in the correct order

Example: Genesis chapter 1, Genesis Chapter 2  etc. all the way to revelations.

The resume (fake bookmark feature) works.

I hope that helps you. I just figured this out 2 weeks ago.

I know that others use different programs to tag which may make tagging easier. I just tag as I go and it seems to work for me.  This is my first mp3 player.

Message Edited by sahm on 04-23-2009 09:06 AM

Ya, in all honesty as long as you don’t plan to use the new Folder view navigation feature that was added in the lastest firmware, or are not concerned about some of the other things (like CD numbers)… it’s really pretty easy to get things to play in the right order on the Fuze (music, audiobooks, even podcasts).

About the only things the Fuze really cares about is that the Genre tags for all the files is the same, that the Album Name tags are all the same, and then just have the Track tags number from 1, 2, 3, on up. All the other tags can basically be left blank or empty.

For some it’s hard to get even just those 3 things set up properly.

Of course, it’s nice to also put something in the Title tags so that the Fuze will display that instead of a filename when it plays the file(s).

The more advanced users can add other things into the other ID3 tags. A program called MP3Tag makes it pretty easy to do all that stuff.

Once all the tags are set up, then it’s also pretty easy to run the files thru some software to alter the file names so that they have the proper numbers in the filenames so that they display in the correct order in Folder view also. I think even MP3Tag might have a built in feature for altering the filenames (although I’ve never used it for that purpose).

Each person has their own way they like to have things done or how they want things grouped.

Anyway, if you don’t plan to use the Folder view all you should need is to get the main 3 tags mentioned above set up correctly.

If you do want to use the Folder view, then all you have to do is make sure the actual file names are set up correctly like 01 something.mp3, 02 something.mp3, 03 something.mp3, etc.

Either way really isn’t all that hard to do. Anything beyound that just depends how fancy you want to be with things.

Hello,

thank you for your detailed explanations :slight_smile:

I have got remarks:

The disc number ID3 field _is_ used by the fuze. But I read it may not play the titles in the correct order when the disk ID3 tag is no number as it should be. “1/2” is_not_ a number, it is a string.

To get the fuze play audiobooks in the correct order I suggest you set the file number field and the disk numer field to the correct numbers.

So just put the CD numbers “1”, “2”, “3”,… in the disk ID3 field - then it should work. Or, if your audiobookhas more than nine CDs, “01”, “02”,… “11”,… And put the track numbers “01”, “02”, “03”,… to the tracks. No slashes.

I never had problems any more since I number my audiobooks like I tried to describe above and since fw 1.1.22.

And the correct “Genre” ID3 tag is “audiobooks”. But this doesnt matter as long as you copy the audiobooks to the AUDIOBOOKS-folder.

Ciao banty

Message Edited by banty on 04-23-2009 07:53 PM

@banty wrote:

The disc number ID3 field _is_ used by the fuze. But I read it may not play the titles in the correct order when the disk ID3 tag is no number as it should be. “1/2” is_not_ a number, it is a string.

As I had mentioned, the Fuze _can_ make use of the disc number tag, but it’s not always needed. It depends on how you set up the track number tags.

If you start with 1, 2, 3, and then just keep going on all the way up then the disc number tag can be left empty.

It kind of depends on what you might want to do with the files later (like maybe burning back to CD’s). Most people just want to get things to play in order on the Fuze and don’t think (or even care) about anything else. So, for them, just setting up all the track numbers may be good enough.

The same is true of the slash “/” stuff. Although it’s nice to have the tags show disk x of x discs and track x of x number of tracks on that disc it’s not something that is always needed either.

To each their own. Some just want down and dirty simplicity, while other want better organizational capabilities. As for myself, I usually don’t have to mess with things very much because all the tags (usually) are close enough to correct for the things I get. But, other people aren’t always as lucky with the files they get.

@banty wrote:

And the correct “Genre” ID3 tag is “audiobooks”. But this doesnt matter as long as you copy the audiobooks to the AUDIOBOOKS-folder.

If you take a look at the drop down list Genre in MP3Tag its “Audiobook”.

However, you are correct that the folder(s) on the Fuze do have a “s” on the end. Depending on if you are connecting in MTP mode or MSC mode the folder will show up as either Audiobooks or AUDIOBOOKS. All the (default) folder names are full caps when in MSC mode.

Personally, having to mess around with 2 different USB connection modes sucks. I really wish that all the player manufacturers had faught against Microsoft’s foolish new idea of MTP. After all MSC mode works much better, and it even worked fine for DRM’ed music until Microsoft decided to mess things up.

As one of the originators of this post/issue, thanks to everyone for the suggestions.  I acknowledge that ordering all the tracks (over multiple CD’s) with consecutive numbers will be a work around.  I am currently doing this to be able to listen to my current audiobook.  However, I prefer to start my track numbers at 1 for each subsequent CD.

More observations/notes:

My track numbers have leading zeros.  My CD numbers do not.

My track numbers are all less than 99.

Unless I’m missing something, my CD numbers are not being recognized.  My audiobook files only show in order by Track number.  Beyond that, it appears to be random.

Interesting: Do you see the CD number in the Track Info data? I do not.  I do see the Track number only.  Wonder if they’re incorrect somehow.  AFAIK, they’re just 1, 2, 3, … , 26.

FWIW, I am using the latest firmware: v2.02.26a   However, I had this issue before the last firmware update.  (I think I had a firmware ending in 17 before.)

To be more clear, I actually had mixed results before the firmware update.  I had books where the CD number was used in track ordering, and lately just before I updated, the CD number was not used.  I updated to see if it would be fixed. No luck.

I have had this trouble in the past also. Recently, for months, I have been playing mp3 books I purchased on CD which came with sequential track numbers by chapter. This latest 4 CD set reminded me of the previous issue, that I did not resolve.

My track #s do not have the leading zeros. Some have played on a car CD/mp3 player in file name sequence, but needed the leading zeros also. I have never used CD #s.

Lately I use the advanced properties of Windows Explorer to edit the ID3 tags, and the CD # does not show up under any of it’s editable fields.