Audio book tracks in wrong order

I’ve loaded an audiobook on to my Fuze+, but cannot get it to play the tracks in the correct order (I don’t really want to know who the murderer was half way through). The strange thing is that when I look at the folder on my PC, it shows the files in the correct order, but on the Fuze itself the track order is 9, 8, 7, 6, 5, 4, 3, 2, 18, 17, 16, 15, 14, 13, 12, 11, 10, 1. The tag details are identical for each track, and I’ve tried reloading a couple of times with the same result. (NB I’ve put this book into the music section of the Fuze removable disc because that’s where I tend to put everything!) Other audio books have been loaded satisfactorily and I’m running Version 02.38.06F. Can anyone help, please?

Try adding leading zeros to the single digit track numbers, eg change to 01, 02, 03… 09.

@grandsire02 wrote:

The strange thing is that when I look at the folder on my PC, it shows the files in the correct order, but on the Fuze itself the track order is 9, 8, 7, 6, 5, 4, 3, 2, 18, 17, 16, 15, 14, 13, 12, 11, 10, 1.


You’re looking at the file names on your computer. Your Fuze+ is looking at (and sorting by) the ID3 tags , not the file names.


Leading zeros (as mentioned) is a must with this many files iin 1 book. but you must add them to the tags. A good tool to use is MP3Tag.

"You’re looking at the  file names  on your computer. Your Fuze+ is looking at (and sorting by) the  ID3 tags , not the file names. 

Leading zeros (as mentioned) is a must with this many files iin 1 book. but you must add them to the tags."

Can you explain precisely how to modify the ID3 tags using Mp3tag. I’ve used it to insert Track numbers 01 to 18 against the relevant files but the Fuze still presents the files in the wrong order, so I think I’m missing the point somewhere…

I’ve never had that problem but if it was me, I’d be trying to get the tracks into the right order using Windows Media Player.

If you’re only going to listen to it once, you could try deleting tracks 10 to 18 on the Fuze, listen to the first half, then reload the book when you’re ready for the second half - which might, or might not work.

Have you looked around the board for a solution?



Thank you, Alanj, but my second posting was asking for advice about using MP3tag. Can anyone assist on that specific point?

grandsire -

You may want to look at my post - I put there a short comment regarding the use of Mp3 to change the title tags.

You may still have to add the "0"s manually though there is also a way to do it by the Mp3Tag automatically (but may not worth the effort to explain it here).

Good luck

If you uses Explore you can fix this problem in you player and leave you original copy as is.  Just drag the folder in you player from Audio books to music, or from music to podcast and this will trigger a move command. Stay on the same drive on your player (internal or external.)  The player will drop the MP3 title and use the file name as the title.  The book will play in the same order that it plays on your computer.  

If you like the original MP3 title, as I most often do, you can use the rename the file in Windows Media Player.  You will just need to rename the single digit file from 0, 1, 2,…9 to 00, 01, 03,…09.  I use the Advance Tag Editors in Windows Media Player by right clicking on the name of the mp3 file.  The reset is obvious.    

For me, these options are safe and very easy.

Is it possible to to have the fuze just play by file name like my clip did? I figured buying a newer device I would not lose features. WIth my clip I could jsut put all my audiobook MP3s in a folder and copy that folder. Presto, all my books list seperately and play without issue. Been screwing with this playing for a couple hours. very disappointed there are not addtional options.

Just copy them into the Podcasts folder (Unless they’re audibles, which, I think, go in the audibles folder) . You’ll then get a Books folder in the top-level menu, tap the centre of the control and you’ll see your books listed. Select a book and tap play/pause to start playing, or select a book and tap centre of control and you’ll get a list of chapters. You’ll see a little white marker on the left if you previously quit in the middle of a chapter - selecting that chapter and tapping play/pause asks if you want to resume where you left off or start back at the beginning of the chapter.

Persevere, It works well when you get used to it.

I’ve got the same problem. It simply won’t play the tracks in the correct order it seems to make it’s own mind up as to what order it will play them.

I’ve numbered all the tracks 01-12 with ID3 tags… check

I’vve numbered all the filenames beginning with 01 - 12… check

I’ve used trailing 0’s (zero’s) in all the filenames and ID tags… check.

I’m using the latest player firmware as updated by the updater software on my PC… check.

Still doesn’t work. It will only let me choose the first 2 track or the last two track, if I attempt to scroll down it simply ignore me, untill eventually it takes you direct to the last 2 tracks. Nothing else inbetween is selectable.

It got around it by copying all the tracks to the MUSIC folder and then everything plays fine and in the correct order, no trouble. It just won’t play in the Audiobooks folder.

Software glitch I reckon.

They should be put into the Podcasts folder. They will then appear under ‘Books’ and the chapters will play in the correct sequence.

That did it, thanks!

I have have started using the Podcast folder in lieu of the audiobooks folder and found that solved a lot of problems.

However, I have recently run into a few audiobooks that not only played out of order, but the track numbers shown on the Fuze+ were different from what they were when I loaded them from the computer.  What is more, when I transferred the folder back to my computer … they showed the correct order and numbering.  I always check the tags before loading the audiobooks with MP3Tag,  and yes … I always ensure there are leading zeroes on the track numbers.

What I think the problem is that the Fuze+ firmware looks at the 'Title" (ie first box on MP3Tag screen) as well as the track number.  The books I had problems with seemed to all have identical data in the title field, but no variable.  For example, all of the title fields had just the name of the book (ie Lord of the Rings)  Audiobooks where the Title field was blank, or where each file was different (ie Lord of the Rings 01 , Lord of the Rings 02 etc) worked fine.

Another thing to get in the habit of checking before transferring to the Fuze+