mount issue in ubuntu 10.04 [solved]

Encountered an issue with my sansa fuze+ in ubuntu 10.04. Yesterday, my fuze+ mounted just fine in ubuntu. Today I plugged the device into a usb port and ubuntu recognized that the fuze+ was plugged in to the computer, but ubuntu would not mount the device. I tried formatting the fuze+ and resetting it to no avail. I tried connecting using both MTP and MSC modes and the problem persisted. I solved the problem by manually mounting the device in a terminal window.

The first thing to do is create a mount point in /media called “fuzep” using the following command:

sudo mkdir /media/fuzep

The second task is to determine the name of the device using this command:

sudo fdisk -l

This command will list every drive on the computer. Look for a fat32 device. My fuze+ was listed as " /dev/sdc1".

The third step is to mount the fuze+ to the previously created mount point:

sudo mount -t vfat /dev/sdc1 /media/fuzep -o uid=1000,gid=100,utf8,dmask=027,fmask=137

This process manually mounts the fuze+ to /media/fuzep. I don’t know if this process renders the fuze+ visible to applications such as rhythmbox or not, as I don’t use that function; but I am able to copy files to the fuze+ just fine.

More information can be found here:

Note: This problem seems to occur when another usb device is plugged in to the computer. When this problem occured, I had a usb hard drive also plugged in. Unplugging the usb hard drive resolved the issue and the fuze+ functions normally now.

Awesome find!  Thanks for posting your results.

Bob  :smileyvery-happy: