Fuze wont work now!!!!

My son just got a Fuze for Christmas and he was messing around one day while it was plugged into the computer and before asking if it was ok to Format the Fuze he went ahead and did it. Now it wont work. It deleted all his music, pics and video’s. Now when I plug it in the computer it wont recognise it and I cant load anything onto it. Can anyone help with this? PLEASE!!!

I don’t think this will fix it but you may want to try downloading the Firemware Updater app.  See if it will see it.  If so then update the firmware then try to reconnect it.  I can’t believe that the Fuze would have dropped it’s firmware during a format but maybe it did.

Dose any screen come up at all on the Fuze displa while it’s diconnected from the PC?


When its plugged in I can access all features on the menu but everything is gone and my computer doesnt recognise that its even plugged in. Usually when I plug it into the computer the computer makes a light “ding” sound and it shows up on my task bar that it is connected but now it makes no sound and doesnt show up on my task bar. My cpu just doesnt even recognise that its there. I did dload the Firmware Update, crazy thing is it says “make sure your fuze is connected and press finish to install the update”, but I have the problem of my cpu not recognising that it is plugged in. Its really quite strange.

what operating system are you running? Windows XP, Vista, Linux?

Also, do you have any other machines to test the fuze on?

I take it the machine has since been powered off and restarted too?

Im using XP. I thought the same thing about trying a different computer so I tried on another computer that we have which also uses XP and I tried it on my laptop and I get nothing out of all three. I can still put in a sd card though and it reads the music but nothing happens when I plug into a computer. Yeah I’ve restarted the Fuze and my computers just hoping that would also work.

Did he format it using XP or the built in format function of the Fuze?

Turn the player on and format it using the player’s menu. After that, try connecting it to the pc again.

Yeah he formatted it using the feature in the fuze. I also formated it again and plugged it back in and nothing happened :mansad:

Check the USB mode.  After formating it may have changed.

Plug the fuze in and then go to the control pannel, then go to system, and device manager, Scroll down to the USB ports are there little yellow triangles on them? If so you are experiancing a driver issue which could happen after an improper ejection. Try to upgrade or toll back your Drivers. Aslo XP is up to Service Pack 3 do you have that? Try to do that stuff.