Mac not recognizing my Fuze in MSC

I have a Macintosh running OS X, so I was excited to see that the Fuze should show up like a storage device, but it’s not happening. I made sure the Fuze is in MSC mode, turned it off and back on again, and plugged it in, but it won’t appear on my desktop. What’s also frustrating is that when I run Apple System Profiler, it lists the Fuze (by name!) as connected to the USB bus… Any tips or tricks for getting this to work? Have people had trouble with Macs, or do I have a bad Fuze? Thanks, everyone! - Johnny

do you have access to a PC?  try changing the label of the drive (on my computer, right-click then rename).  this usually works.

Thanks for the tip - I might be able to give that a try, but of course if I had free access to a Windows computer, I wouldn’t have this problem in the first place… Are you talking about just changing whatever name the Fuze has? When I get it to mount on a Windows desktop, I should change its name from “SanDisk Sansa Fuze” (or whatever) to “drive1” or something? I’m willing to give it a try, but does a device’s name make that much difference? Maybe more so on a PC than on a Mac… Another question is: How much of this should I try before I take it back? If the Fuze is supposed to show up on my desktop like a thumb drive (I have no trouble mounting those), shouldn’t it do that out of the box? Thanks again, everyone reading this.

when the fuze i connected to your mac in msc mode does it show up in system profiler? if so check the /Volumes/ folder, this is where all drives are mounted by default. there should be no need to rename the drive.

Message Edited by drlucky on 06-16-2008 04:58 AM

This is also happening with my fuse. It seems like the profiler recognizes the device, but no icon is mounted on the desktop to click on for access. What to do???

@johnnyquest wrote:
but does a device’s name make that much difference?

yes.  mac uses the device name as a mount point (since there’s no drive letter).

marqck, I’m starting to like you - not only were you the first to answer, but your last response was very sensible and to-the-point. (Also, that’s very interesting about the Mac using names as a mount point - of course without drive letters it would need some sort of metadata or to use the name. You learn something new every day…) I chickened out on changing the name today (I plugged the Fuze into a PC to see if it would recognize it, but I didn’t actually do anything once it did), but I’ll give that a try! (And report back for humblebumble and others…)

Having the same problems as previous Mac posters.  My Fuze shows in System Profiler though no where else.  Checked volumes. Not there. I have one added glitch, my iMac freezes if I try anything else.

I have updated the firmware on my PC at the office.  I have reset to factory settings.  I have formated as well.

All to no avail. 

I really want to use the Sansa Fuze and not go for an iPod.

Any other suggestions? 

Message Edited by NormZ on 06-16-2008 05:28 PM

It is with much sadness that I report no success.

I plugged the Fuze into a PC, navigated to it, and right-clicked in the window. There was no menu option for “rename,” but I went to Properties, and there was a name box at the top of the “General” tab. I changed the name there (it was SANSA FUZE and I changed it to FUZER), but now I bring the thing home again, and my Mac refuses to budge. I looked on System Profiler, and the Fuze was still showing up (it is still listed in Profiler as “SanDisk Sansa Fuze,” though, so when I changed the string “SANSA FUZE,” I obviously wasn’t getting to the name I need to change…)

drlucky, I could not find a folder marked “/Volumes/” in System Profiler or anywhere on my Mac (I searched).

I’m also waiting to hear back from Customer Support, but that is a sloooow process, so I’d be happy to hear any other ideas. Can anyone out there tell me another way to rename something that’s plugged into a PC? It’s so easy on a Mac…

Watch this thread for updates, because by the end of the week I’ll either have: a)the problem solved, b)a replacement Fuze that does as it’s supposed to, or c)returned it and purchased something different (don’t make me buy a Coby, please!).

  • Johnny

to get to the /Volumes/ folder you need to select go in the finder menu then go to folder. make sure you type exactly /Volumes/

i use my fuze and my macbook air and macbook pro (both running OS X 10.5.2 leopard) with no issues in both mcs and auto detect . what version of mac OS are you running? also what firmware is on your fuze?

Well, I am running an older version - OS X 10.3.9, but when I’m at the desktop (Finder), the Finder menu has “About Finder,” “Preferences,” “Empty Trash,” and “Services” but no listing for “folder” or “/Volumes/”.
And I’m sorry, but I’m a little confused - you said to go to the menu, but then I have to type “/Volumes/”? Where am I typing?
My Fuze firmware is V01.01.11A.
Gotta go - thanks for the ongoing conversation!

Is the Fuze listed under Disk Utility?  Finder/Applications/Disk Utility

My fuze is not recognized on the disk utility in 10.3.9

It is located under the go dropdown menu and is called go to folder.

Thanks, humble, I finally found the “/Volumes/” folder, but the Fuze was not there.
Likewise when I tried Disk Utility - no Fuze.
Thanks for the continued suggestions…

Same here.  Running Mac OS X 10.4.11 and the Fuze is the most current firmware (flashed it yesterday).  Sent in an EBox support request, this is what I received within about 12 hours.

“Let us try to force the player to MSC (Mass Storage Class) mode. To do so, please turn on the player then slide the power button down to put the player on hold. Press and hold the rewind “|<<” button while plugging in the player to the computer. Do not let go of the left button until the screen of the player says “Connected”.”

I tried it a couple of times with the same results.  Shows in System Profiler and nowhere else.  My iMac also freezes within about a minute of being connected to my Fuze.

Jeez, I really don’t want to change to an iPod, the Fuze has what I want and an iPod doesn’t. 

Thanks for the update, NormZ. I also tried to follow those instructions, with the same (negative) results. I suppose I’m lucky, as my Mac Mini hasn’t been freezing up over all this! Actually, I’m pretty sure the Fuze is already going into MSC mode, because when I plugged it into a PC it mentioned the Sansa Fuze by name, but it also gave me the message that a mass storage device had been connected.

Here’s another interesting thing (although unrelated to Mac connectivity, I think, and may just muddy the waters - sorry), but the PC assigned the Fuze to both the /E and /F drives. Is this because of the Fuze’s card slot? When I tried to access drive /F, it asked me to insert a disk, so I think it’s reading the Fuze’s card slot as an additional (empty) drive. Can anyone confirm this?
(Maybe it doesn’t matter, but the manual doesn’t talk much about how the Fuze deals with memory cards, and I’m trying to learn as much as I can in anticipation of this thing finally connecting!)

Thanks again, everybody! I think it’s my turn to have Customer Support write me back, so I’ll let you know what they say. (But I’d bet you a dollar it’s going to be: “Let us try to force the player to MSC (Mass Storage Class) mode. To do so…”;))

Message Edited by JohnnyQuest on 06-17-2008 09:29 PM

sorry for the late reply.  i think the reason why you didn’t saw the rename option when you right click on the fuze is because the device was still on MTP mode.  now that you have it on MSC please try it again.

OK, I’ll have access to that Windows machine again tomorrow, and I’ll give it a try.

Still no response from Customer Support - over three days since my initial contact, and two days since I provided them with the additional info they requested…

Seems I am having better luck with Customer Service in some regards.  I keep getting responses within 12 hours of sending them through eBox.  In any case I am calling Apple Customer Service this evening as I am still under Apple Care coverage for another four months. I even ran the TechTools that came with my AppleCare subscription.  All checks out fine.

The latest responses from Sansa haven’t really been helpful.  I am able to connect to my WinXP computer at work and transfer files, so I at least get music on the way home.

Two nights ago the big brushoff by Andrew G.

"Thank you for contacting SanDisk Technical Support. We appreciate your efforts in helping us resolving this issue.

We have now confirmed that the player is working properly. We strongly recommend that you contact your computer manufacturer to give you further assistance with regard to this matter.

Should you have any other concern with our products, feel free to contact us again.

Then I think his supervisor saw his response and placed my file into another agent’s hands.  Friendlier, though not much better, though I don’t blame her for this response.

As stated in your previous email with another agent, your player is working with a Windows XP computer. It only shows that the player is not defective. The issue now is with your computer. Please do try the player on another Macintosh computer. Please check if the same issue will occur.

So now off to see the wizards at Apple this evening, as I do not know anyone close by that has a Mac and the Apple store is a 45 minute drive on the highway. There may be a dealer closer, so I will check.

Keep you all posted!

NormZ

Message Edited by NormZ on 06-19-2008 09:15 AM