Mac not recognizing my Fuze in MSC

Well I have tried my fuze on 3 macs and not a thing. This really smells of a sansa problem. I don’t understand how others seem to be able to connect on a mac…Is it fuze size specific as mine is a 8gb silver. Are the ones that connect this size or smaller?

Well, no luck with Apple Care.  They said that if it is a third party player they can’t help and suggested that I post the issue to the Apple Discussion forums.  In reviewing all of the posts in this thread I noticed that Dr. Lucky has no problems and from the description of his Mac gear I think it is not a hardware issue and more of a software issue.  Correct me if I am wrong Dr. Lucky but are your two Macs running Leopard?

Panel?  Are those having problems with their Mac and the Sansa Fuze running Tiger or Leopard?

I am running Tiger, guess I will have to upgrade to Leopard… 

Got a response in my eBox from SanDisk - the whole message was a set of instructions for renaming the Fuze, which is basically what I got from marqck four days ago! Well, I did ask, I guess, but they’ve totally sidestepped the question of getting it to mount on a Mac desktop. (Because, though it was a good idea, renaming the Fuze didn’t get it to mount.)

I’m curious - those of us with a problem seem to be running OS X 10.3 or 10.4, and while drlucky said he had no problem, he’s running 10.5.2…
Do you think our friends at SanDisk have checked this thing on any but the newest version of OS X? I have a feeling we’re up the creek with our older versions (much like if I’d bought an iPod nano - that won’t work with system 10.3 either!).

Here’s the workaround I came up with: the card slot. I can’t access the Fuze’s internal memory with my Mac, but putting a microSD card into my card reader works just fine, and then I can put the card into the Fuze! This leaves just a couple of problems: First, you’re limited to however much you can fit onto a card, but with up to 8GB cards available, it’s not too big an issue (for me at least). Second, all the Fuze’s internal memory is going to waste. So today I loaded as many mp3’s as I could fit on a 2GB thumb drive, and took it over to my Dad’s house to use his PC. He had two USB ports free, so I plugged in the Fuze and the thumb drive, and transferred them all over. Now, this means that what’s “onboard” is kind of static, but that’s OK for music - I’ll use the microSD card to put podcasts and new stuff on and off the Fuze. And if I want to change it, I can go back to my Dad’s, or heck, I should be able to do a little drag-and-drop at the public library, if I need to.
I know, it’s pretty convoluted, but what else are we to do? I mean, can anybody recommend a decent mp3 player that will work on a Mac running OS X 10.3?
I didn’t think so.

I’ll let you guys know if I get any better response from Customer Service, or if anything else comes up, but in case this thread dies out at this point, I’d like to say thanks again for the help, and good luck to my fellow MacFuzers!

These recent system updates are so useless, I refuse to learn the silly cat names, let alone upgrade. And I’m not about to spend $129 just to get my $80 mp3 player to work! Tiger is 10.3, right? Panther is 10.4 and Leopard is 10.5, or is it the other way around?

Hey, this has nothing to do with the Mac, but I confirmed my earlier suspicion: Windows looks at the Fuze, and assigns it two drive letters: one for the Fuze itself, and another for its card slot. When I mounted this thing on a PC with a card in it, it showed them as two separate drives. The Fuze seems to integrate the items on the card right along with the items in main memory, which is good. The one feature I’d like would be the ability to transfer files from the Fuze to and from a card in its slot, but I think that’s a whole other piece of architecture…

Also (again, sorry, off topic) I noticed that the Fuze comes with a few songs, some photos, and a video built in, but when I look at the Fuze (on a PC) the folders are all empty. Where’s all the data, man?!? Where are they hiding those cat photos? Creepy.

Are you referring to the stock photos on the Fuze (samples)?  They won’t be visible in the file tree while connected in MSC mode on a Windows machine; the files were initially loaded in MTP mode.

I’d love to get my hands on one of those wee “Mini Macs” I’ve seen (the little guy that looks like a CD player) just to relearn the ropes of the Apple, and to play with compatibility issues.

I used to have a collection of Apple II units (yeah, years ago), the first Apple “portable”, and the hybrid PowerPC, if that is any indication of the timeframe.

Bob  :wink:

Well, Folks!  I think we have exhausted this thread.  

Me!  I am going the route that Johnny Quest has taken.  Keeping my Fuze and applying a workaround.  Already have a card reader, so I went out and purchased a microSD card with an SD adapter (Sandisk brand, of course) transfered 2 GB of music to the card using SychTunes (get it here:  http://www.nesfield.co.uk/synctunes/) and then plugged it into my Fuze.  Voila!  Music!  So I am happy, just one little extra step.  As for the 2GB of memory onboard the Fuze, I’ll just fill that up with audiobooks using my wife’s PC.  Just have to keep my fingers crossed that the little card reader I have will be able to read the microSD HC cards when I get around to buying a couple of those in the future.

BTW, I highly recommend SyncTunes.  Great little application that gives you near iTunes music transfer/synch ability.  The developer seems to be a part-time software writer, does not ask for payment though requests donations to a specific charity, Diabetes UK.

Till later and happy Fuzing!! 

Message Edited by NormZ on 06-20-2008 09:02 PM

Hey! Johnny Quest!  The mysterious files you were trying to find are not really hidden. I read somewhere else that they are only visible if you have your Fuze set to MTP rather than MSC.  Seems that what shows is determined by how the original files were transfered into the device.  If you switch to MTP and then plug into a Windows PC you will see them and not anything else.  Those sample files were loaded by Sandisk while in MTP mode.

Till later! 

@normz wrote:

Well, no luck with Apple Care.  They said that if it is a third party player they can’t help and suggested that I post the issue to the Apple Discussion forums.  In reviewing all of the posts in this thread I noticed that Dr. Lucky has no problems and from the description of his Mac gear I think it is not a hardware issue and more of a software issue.  Correct me if I am wrong Dr. Lucky but are your two Macs running Leopard?

Panel?  Are those having problems with their Mac and the Sansa Fuze running Tiger or Leopard?

I am running Tiger, guess I will have to upgrade to Leopard… 

i am running leopard on both my macbook air and 17" macbook pro. both have no issues detecting the fuze.

Now here’s a bizarre development:

At this moment, my Fuze is plugged into the Mac (to recharge it, I thought), and the ding-dang thing has decided to make an appearance on my desktop! I can access all the files and everything. BUT I DON’T KNOW WHY!

I’ll have to do some testing, but here are the conditions that made it work:
Earlier I went to the login window, and put the computer to sleep (my whole family is still “logged in,” so that doesn’t seem to matter). Then, I plugged the Fuze in to charge it, and that action woke up the computer (not surprising). I left the Fuze plugged in to charge (with the login window showing) for about an hour, then signed into my account, and I see not only the Fuze mounted there, but also the 2GB card I put into the Fuze (also mounted separately on the desktop).

So, Normz and everyone else, try plugging in the Fuze while the computer is asleep (or at least at the login window), and see if that works. Maybe now that it’s here, the thing will mount more easily in the future…

I will post here again to follow up!

Johnny Quest!  Thanks for the update.  Tried it this morning, though quickly.  Didn’t seem to work.  Was your Fuze powered up or off when you did it?

Thanks!

This sounds very promising…however it did not work with my fuze just now. I am using OS 10.3.9 and have the 8GB silver. I have tried it in msc, but will try it with auto just to make sure. I wonder if yours mounted because you had a card with “mac” data on it. Perhaps I need to get a card reader as you have done. Does your fuze now mount up when you disconnect it? Thanks, Ron

I don’t know if this has been mentioned, but working in the computer hardware industry, (we make KVM switches) I have found that some OS’es take literally forever to enumerate USB devices sometimes.  This has been a common complaint amongst some of our USB KVM switch users.

I have seen certain units take literally minutes to show up.

Perhaps that is what is going on here.  I don’t know how long you guys have plugged the unit in for, but perhaps it just takes an inordinately long period of time to enumerate under the earlier Mac OS versions.

I would attach the unit and walk away for 15 min, 30 min or an hour and see what happens.  If it does eventually show up, at least you can then load to it.  It’s a bad compromise, but at least it’s functional…eventually.

Just a thought

Quick update (have to take my kids to t-ball) - the Fuze only mounts when I have the card installed. When I take the card out, the Fuze doesn’t show. It was a card I had previously mounted using my card reader, so it looks like you’re right, and that the Fuze is (begrudgingly) appearing because it’s the vehicle for the card that the Mac can already see!
Card readers can be as little as five bucks, now, so that might be the way to go.

p_opus:  Great info!  I will try that myself, maybe that is why my Mac is freezing.  It is trying to enumerate (?) the USB connection from the Mac.  BTW, does what you suggest mean that once the device is enumerated that it will be picked up faster on future connections?

JohnnyQuest:  Excellent!  Though I have not had the same success.  I bought a 2 GB microSD card and it doesn’t show like you have experienced.

Keep on truckin’ !  Somewhere along the line a connection will be made. 

Well the free 512MB sansa sessions card showed in the mail here last week. I never had opened it as I really was not interested in the contents, but more so in the card itself. It seems the card may have a purpose after all in the form of a “'key”…who knew? Well after reading JQ’s luck with a card I went ahead and opened it up and thrush it in the fuze. Low and behold the darm thing mounts it first as “'sansa music” and then a second later it mounts the fuze itself as “sansa fuze”. Without the card the fuze does not mount at all. Prior to this revolation I spoke with sansa and they said it was an apple problem so I dubiously called apple who naturally said it was a sansa problem. Not being an expert it is so very easy to see who is at fault with this bug. Hey Sansa why don’t you fix this little problem so your product works as advertised on your website!!! Mac OS is Mac OS and it should not be this difficult to fix. This was after all a major reason that I purchased your product was the advertised dual compatability…in addition to the other nice features that it pocesses. If this mounting issue were resolved and a line out option for video and pictures were made available I would have to give you a 10, but for now the frustration problems with the product and service brings it down a few pegs. Ron

I just received my Fuze 8GBs in the mail today.  I have OS X 10.3.9 and a PowerBook G4.  After hours of playing around with it and trying to troubleshoot with a friend of mine, we figured out that by putting in a MicroSD card both the internal memory and the card would pop up on the desktop in OS X.  So apparently the fix for those in 10.3.9 (and it sounds like 10.4) is just to have a MicroSD card always plugged in.  Easy enough.

But now there’s a new problem.  Every time I eject those two drives (the internal memory and the installed card), and then unplug the Fuze, OS X always tells me that I have disconnected the USB device improperly by not ejecting it (even though I did eject it).  I even tried turning off the Fuze after ejecting everything, and then unplugging it.  I still get the same warning in OS X about unplugging it improperly.  Anyone have a fix for this?  Will this damage the device over time?

I tested on my 10.5.4 Mac (all I have) and both drives show up on the desktop and I am able to drag both drives to the trash and eject it properly.  My device is in MSC mode. 

Don’t bother with any of the renaming nonsense.  Make sure you plug the sansa into a USB port ON THE COMPUTER… NOT on a USB hub.  It will then show up on the desktop.  Just discovered this today after running into the same problem as you did.  Note:  The hub I was using was a Belkin.  Other hubs MAY work.

Jack 

I have a G5 iMac System 10.4.11 - I had set the Sansa Fuze Usb settings to MSC mode.  It refused to mount on the Mac and was not visible in the System Profile / USB.

When l replaced my Apple / Nana / USB leash with the USB leash from Sandisk, the Fuse immediately was visible on the Mac desktop, and I was able to rename it, and it also appeared in the Mac System Profiler / USB 

   My daughter had loaded music and pictures on the Fuse but they were not visible on the Mac finder.

Hmm.

Ian Campbell 

whitenorth-

BE VERY CAREFUL NOT TO USE APPLE ACCESSORIES WITH THE SANSA 30-pin port!!

The 30-pin connector for the Sansa is slightly different from the Apple counterpart.  Have a closer look.  You’ll note that the tabs on the outside edge are a wee bit different.  Not different enough, in my opinion, but that’s the way it worked out.

NEVER try to plug the Fuze into a dock made for the iPod, as it will place power on the wrong pins, and damage your Sansa!

Bob  :dizzy_face: