Micro SD card freezes player

My Clip plays the music on its internal memory just fine, but when I put in my 4G micro card it freezes up.  My computer recognizes the micro card just fine, when the player is connected to the computer there are no problems with adding or removing music on the 4G card .  But when I disconnect from the computer I have to remove the 4G card or the player remains frozen on the “sansa logo” screen.  Once I remove the 4G card and reset the player it will refresh the media on the internal drive and play those songs just fine.  Do I need to give up and buy another Micro card?

There’s a file on the microSD card that’s giving the Clip more than it wants to handle, most likely.  As the device sweeps through your music files, if there’s one with a problem in the file, the player may freeze.

If these music files are from your computer, simply format the bard, and load it with music a few files at a time, until you find the troublemaker.  You can connect the card via a card reader and use the chkdsk utility to see if that helps, or use manage via a right click on My Computer, go to Tools, then Check Volume For Errors.

Bob  :wink:

I had some micro SDHC cards from eBay which locked up my Sansa Clip+ every time I changed the files on them. I returned them and got some decent ones and everything’s fine now.

I really hate hearing of these defective card issues–the reason I tend to buy my cards locally …

I regret to say that didn’t fix it.  I tried reformating the card, then I tried a brand new card and it still doesn’t work.  When I plug the Clip in without the micro card the internal storage works fine, but when I insert a micro card now the computer says “USB Device Not Recognized” and won’t allow me to access either the internal OR the external storage.   I have tried it on both my laptop and my work PC with the same results.  Something must be wrong with the Clip’s ability to recognize a micro card?  I wish I could update the firmware but the Sansa Updater is worthless, it only lets me download the instruction manual.

1 Like

Still within warranty/time to contact SanDisk for a warranty replacement?

Try setting you player to MSC mode (Settings > System Settings > USB Mode) and see if that changes anything.

I’m having the same issue (on a clip+ 2gb) with a 8gb sandisk sdhc.

I think the problem is the firmware. because using rockbox the sansa works (but unstable), but with the up to date sansa’s firmware the player freezes.

I have tried with another 8gb sandisk sdhc, the same issue. they both works fine in any other task.

with an 4gb kinston sdhc works great, but I need to upgrade the storage capacity.

any solutions?

Did you try running the chkdsk utility?  Also, have you tried formatting the card with SDFormatter from the SD Association?  http://www.sdcard.org/consumers/formatter_3/

thanks, human being!

sdformatter didn’t fix it,

BUT the chkdsk utility DID IT!

so far, my clip+ is not freezing anymore. :slight_smile:

I love the true minimalist aesthetic of the original sansa, rockbox’s themes are awful, wasn’t an option to use such horrible theme.

thanks again, miikerman. :slight_smile:

Great to hear that chkdsk did the trick.  Candidly, I often forget about this little gem when I have an issue, which often seems to do the trick.

@muny wrote:


I love the true minimalist aesthetic of the original sansa, rockbox’s themes are awful, wasn’t an option to use such horrible theme.

One thing to note, although I haven’t tried it: 

One of the Rockbox themes mimics the Sansa Clip’s original interface.  Maybe you want to check it out.


Roxbox Clip+ theme gallery:  http://themes.rockbox.org/index.php?target=sansaclipplus

This regretably is the EXACT same thing that is happening to me. The updater is useless, my sansa player wont recognize any sd card, and it only works lugged in and not with internal settings. The moment i add an sd even a formatted one it freezes both plugged ina nd not. I tried formatting he internals and nothing changes the issue. It really seems as if the device wont recognize sd cards. 

My problem all started when i leaned over from an awkward position to turn on my mps player which is the sansa clip+ 4gb btw. I hit the power button on as the plug slipped out a bit and boom it was stuck. So from start to finish heres my setup when the problem occured. I have a 3.5mm jack plugged in which leads directly to my stereo system, and the charger cord plugged into the player and into a usb compatible power jack plugged into a power cord. I do this so my player when on can continuosly play music while it charges. I have been doing this for about a yer now with no issue, as unlike plugging into a computer it does not chage unless turned on the player can be acsessed as normal and i can turn off and on no problem. The issue was in this scenario i was upset about noise outside so i leaned over to get some music on quickly from my computer chair, i ht power on and the power adapter which doesnt sit tight in the power strip came loose just as i was turning it on, and i am ead to beleive that caused a delay or confusion in the devies thinking which made it freeze on the start up logo. Now why or how this has anything to do with it not reading cards is probably because it was reading the card at that point and now its card reading funcion is stuck or broken. PLEASE , can anyone help me fix this? 

how did you run chkdsk on the sansa clip? or did you run it with just the sd card plugged into a reader? if so which one and how?

If you can get to Settings/System Settings/USB, change it to MSC. I had weird things happen when the unit was in MTP mode and connected to the computer, including not reading the microSD card afterward. 

You can try a soft reset. When the unit is on, hold down the power button for 15-20 seconds, well after the screen goes dark. If you have headphones plugged in you will hear a click. 

You can also try reloading the latest firmware. Use the MANUAL instructions in the firmware update thread. Forget about the updater–there won’t be any more updates so you can take that out of your computer. 

Manual Firmware update

Firmware Download for All Regions - Click here to download


All languages are now in one firmware version. After firmware update you will need to select your Language and Region preference.

• Ensure your battery is > 50% full

• Extract the .zip file into a folder on your computer 
• Once extracted, drag the Firmware file to the root directory of your Sansa Clip+ 
• Disconnect the Sansa Clip+ and let it begin the firmware update 
• Once it finally finishes doing its update, it will turn itself off 
• Turn the Clip+ on Select your language and region preference 

• Once its back to the main menu, head to “Settings” > “System Settings” > “Info”, and verify the “Version” is now 01.02.18

If you can get to settings, you can also take out the microSD and and try formatting the unit with its own Settings/System Settings/Format command. That will erase any files you have put on the unit, so make sure you have copies. It doesn’t make sense that formatting the unit would fix the microSD but…sometimes it works.