Sansa Clip+ and microSD card

I recently purchased a SanDisk 8gb microSD card to use with my 4gb Sansa Clip+, but I can’t get the card to work. Every time I insert it into the Clip, the Clip restarts, shows the word ‘Sansa’ and then freezes on the Sansa logo. I’ve tried updating my firmware, which is up to date (V01.02.16A). I’ve tried formatting the card with the SDFormatter. I’ve scoured the web in search of an answer, but have found no working solution.

Is my Sansa Clip+ defective? The internal memory and all other functions work just fine, but it refuses to cooperate with the microSD card. I bought the card at Best Buy, in all the original packaging and everything, so I highly doubt the card is counterfeit. I bought the Clip about a month ago, and have had no trouble with it at all until now.

Is this perhaps an issue with the current firmware?

Nevermind, gentlemen! I had assumed that the Updater had taken care of the firmware update; my Clip+ was technically up to date, but just now I manually installed the firmware update, and my problem is fixed! Thank you for the helpful replies that I’m sure would have been posted shortly!