Clip+ Doesn't Like My SD Card

So I have a 2GB microSD card, that plays along fine with my new Clip+. However, I have another 8GB microSD card made by Samsung, Class 2, formatted to fat32, that doesn’t get along with my Clip at all. When inserted, most of the time the Clip freezes on refreshing media. If it does get past it, it doesn’t actually scan in any of the files on the card, and when I navigate to the card directory in windows using MSC, it doesn’t think there is a card at all. This is strange, the card works with any other device I have tried. As a matter of fact, it even worked in Rockbox! But I’m not a huge fan of the Rockbox firmware, as it’s kind of ugly, so I’d really like to figure out a way to get it to work on the official firmware. Any ideas?

Sometimes, there are inexplicable incompatibilities.   :frowning:

You might try reformatting the card.  Recommended is the SD Association’s formatter.

Yea… someone actually had pointed me to that program on anythingbutipod, and it didn’t do the trick. Sigh… Oh well, I’m really liking this little clip for the most part, I only have had it three days, but it’s a bit dissapointing that custom firmware seems to support some cards that official firmware made by SanDisk - of all companies - doesn’t. I’m not too big of a fan of Rockbox… 

Thanks for the help! I guess it’s just one of those inexplicable incompatiblities.  

What kind of files do you have on it? And are they tagged properly?

Yea, the files are fine. They are all proper MP3 rips, I can add the same files to internal memory and play them fine, and I’m really OCD about file naming and tagging.

Well, it was worth asking anyway. I’m had issues with the formatting software linked to above; you might try the HP formatting software, or even Windows to see if that would help.

If these other methods of formatting fail, I’m at a loss. I haven’t heard of any compatibility issues with Samsung cards, but who knows? Strange stuff happens.