Media converter not recognizing my Fuze

I have installed, unistalled and re-installed the converter. It does not recognize that my Fuze is connected to the computer, so the
device category at the top left is empty. It therefore will not let me convert anything at all. Are there other converters out there that do work? I have tried the Xilisoft converter, but when i try to add the video to the video file of the fuze, I get a message saying “the file can be stored for transport but is not compatible” (the abridged version of the message). I also tried River Past Crazi video converter and get the same problems. Any suggestions (besides not saving videos at all)??

I have had success with Rhapsody, try it.    It wont convert m4v vids though.

I tried Rhapsody also today with a representative from Sandisk. After 45 mins. on the phone, we still couldn’t get it to work. Rhapsody would recognize the Fuze and accept drag-and-drop with mp3’s, but not video files…they are baffled and are gonna call me back sometime to try and fix the issue.