m250 usb issue

Hi there, I got an m250 for christmas, and then I plugged it in and it worked fine, I was able to put songs onto it via windows explorer using the usb cable.  Now, a few weeks later I dont have access to that first pc that I was using and am using another pc.  I plug the m250 in, and it does not ever see it on the pc itself.  i can listen to the music that i have already put on there.  when i plug it in the usb cable it says ‘usb writing data/msc; usb connecting msc’, then the player starts up on song #1 that i downloaded. particulars:  m250, 4.108a, windows xp sp2, media player 10.  what the heck am i doing wrong?

I had the same problem last night as I just got my M250.  I spent a lot of time looking for drivers etc, then I figured out it was a setting on the player.  You need to go to the menu and choose settings and then choose USB.  Once there you have 2 options: MSC & auto detect.  If you choose MSC your computer should be able to see the player on your usb drive.  It worked for me so I hope it works for you.  

Thanks for the feedback.  The player is in ‘msc/usb’ mode, it says ‘writing data usb; connecting usb’ when I connect it.  However, it does NOT stay in USB mode, it goes right into PLAY mode.  When I did it the first time it did go into ‘usb’ mode and I could see it as a device.  I just tried it on -another- computer right now and it did go into USB mode once. Then I unplugged the USB and plugged it in again and it went back into PLAY mode.  How do I get it to stay in USB mode so that I can put more songs onto it?  I hate to say, this should be simple, not rocket science or something!

it is simple =P, you just have a product that doesnt want to stay connected. Sounds liek sandisk would replace it. Is it less then a year old? did you purchase it new? if yes to both, send an email to support@sandisk.com


Had a similar problem.

Thanks. You just saved me a lot of time.

Message Edited by techdog151 on 01-17-2008 11:10 PM

well i got my m250 as a gift and after i finished installing wmp10 from the CD, i connected the player… it was in MTP mode by default… and it started the ‘Found New hardware’ wizard… after the wizard completed… i get an error saying that the device was not installed correctly and there ar eproblems… i dont find the device as a ‘USB device’ or in the WMP sync tab… in hardware device properties… it shows the error that the there were problems installing the device… i searched for its drivers but i found none… im running WindowsXP SP2 btw…

any help will be greatly appreciated. THanks 

I just figured mine out.  I was having the same issue where it wouldn’t install the device.  If you haven’t done so, do the following

Right click on “My Computer” and select properties

Go to Device Manager and select the USB controller tree

Find the one that has a little yellow icon (this means there was an error when trying to install the device).  Right click on it and select “uninstall” to remove it. 

With your Sansa unplugged from the computer, turn it on and press the menu button (top).  Arrow down to settings, select that and then arrow to “reset all”.  Hit the right direction arrow key and you will see the icon on the bottom right side of the screen turn to a check mark.  Now select that.  This will reset your player back to the factory settings.

Now select “USB”.  Select “MSC” instead of “auto detect”. 

Now power off your Sansa and connect it to your USB port.  Mine took right off and installed the software without any issues.  Hope this helps!!!  I pissed around with this thing for a couple of hours until I tried this!