Long files (more than 40 min)

I found 2 issues with my Sansa Clip 2Gb V01.01.30A - long files more than 40 minutes are not processed correctly.

  1. Player just jump to next file during Fast Forwarding after 25 minute.

  2. If I’ll pause player after 25 minute (for example at 31) and switch it off, than during next switching on player will jump to next file in the list.

Does anyone have same issues?

Here is file example: http://depositfiles.com/files/xgnn7m14u

Try re-formatting your Clip. I had some issues with my Clip skipping parts of audio books that were solved by re-formatting then upgrading the firmware. If you do this,you’ll have to replace all your data.  Since I use mine only for books, it’s a non issue for me as I remove each book after listening.  In fact, I re-format periodically to delete the old book after listening to it.

I’ve listened to books in excess of 50 hours regularly.

Thank you for advice. I’ll try to format my CLip, but it seems to me that it is firmware’s issue - I can’t remember that I had such problems before last firmware update.

Could anyone with same as mine firmware version try the file that I posted as example?

Welcome to the forum, Shamu.

I downloaded the file and I can confirm this behavior on my 2Gb Clip with the V01.01.30F firmware. The Clip seems to recognize it’s length as ~28m:30s, even though it’s actually a bit over 1 hour long. It’s impossible to seek beyond the 28:30 mark, but if left playing it will continue normally. This is probably a bug in the time length calculation. It also happened to me once with a previous firmware (the original .18 IIRC). Something in the file must be confusing the Clip I guess.

have the same problem with the fantragic podcast. you can use a program called winmp3packer.
http://www.softpedia.com/get/Multimedia/Audio/Audio-CD-Rippers-Encoders/MP3-repacker.shtml

the program is designed to convert vbr files to cbr and back but set the output files to vbr to keep the same file size. i have tested your file and it now reports the correct track lengh after proceesing

tk421 is right. I also re-encoded it with foobar2000 (using -V0 and -V6 quality) and the Clip sees it fine. Weird.

I don’t know if this is relevant, but here are the frame bitrate counts for the 3 files I tried: 

original

32: 26860
40: 6522
48: 10553
56: 16591
64: 21714
80: 33750
96: 20712
112: 9705
128: 2872
160: 2786
192: 309
224: 25

foobar2000 (-V0) 

32: 6402
40: 1
48: 13
56: 9
64: 8
80: 17
96: 25
112: 63
128: 139046
160: 1131
192: 385
224: 215
256: 1289
320: 3797

foobar2000 (-V6) 

32: 16332
40: 4775
48: 13843
56: 29225
64: 34207
80: 25232
96: 7004
112: 1925
128: 901
160: 1557
192: 228
224: 1662
256: 5980
320: 9530

I first thought it might have something to do with the low bitrates in the original, but the VBRs generated by foobar also have some low bitrates and they work fine… :neutral_face: BTW, the file is MPEG v1 layer 3, 44100 Hz, mono.

tk421, thank you so much! Your solution really works for me :slight_smile: