Locked up Sansa Clip

I got a 4GB Sansa Clip 3 weeks ago (it was a gift, I would never spend my own money on anything manufactured by SanDisk).  The first thing I did when I attached it to my PC was update the firmware.  Today I was using it (listening to MP3s) while cycling home from work.  When I got home I hit pause and left it on my desk, trusting that it would do as it was set to do and automatically shut down after 2 minutes.  About an hour later I noticed that the control ring was lit up and that on the screen was the logo (a flower?).  None of the buttons would respond.  I used the “reset” function (hold the power button for a few seconds).  Unsurprisingly, this reset function does pretty much nothing.  Scratch that, it does absolutely nothing except bypass the usual software/firmware-based shutdown and force a hardware shutdown (similar to holding the power button down on most PCs for 5 seconds).  I doesn’t actually “reset” anything.  After doing that, it wouldn’t get beyond displaying the flower logo when powered up.  I was resigned to the fact that this was the third (yes, third) SanDisk MP3 player to have becomed bricked on me in the past year, under warranty, and that once again they would completely ignore my requests for them to honor their warranty (they don’t respond to my emails and they put me on hold, only to hang up on me).  I decided to go online and see if others had had similar problems.  It seems I’m not alone in having this problem with the Clip, but for some reason the vast majority of people having this kind of problem were Mac users and attributed the problem to that.  That’s just not the case.  My Clip has never been attached to a Mac (I have 3 PCs, using XP Professional, Vista X86 Home Premium, and Vista X64 Home Premium), and was not attached to anything at all when it failed.  I decided to hook it up to my Vista X64 PC.  At first it reported that an unknown USB device could not be identified because it had malfunctioned.  A few minutes later, it reported that a Sansa Clip had been detected, and the Clip’s LCD displayed the usual “Connected” screen, however it did not appear in Explorer for more than 10 minutes, where it was assigned a drive letter (which meant it was in MSC mode, which wasn’t normal).  I tried accessing this drive letter, which caused Explorer to contemplate the meaning of life for over an hour before I put it out of its misery.  When I unhooked the Clip, it reported “Not enough space for Music DB. Please free up 30MB”.  I had less than 400MB of files on it.  Let’s see, 4096MB minus 400MB is… well, it’s a heck of a lot more than 30MB.  Why does it need 30MB just to store a music database anyway, and why isn’t memory for that function being reserved by the firmware? I reconnected it, but instead of using Explorer, I opened a command prompt and typed “format K:”.  It then prompted me to insert a disk into K: and hit enter when ready.  I considered the idiocy of that prompt for a second, and hit enter.  Then… well, nothing happened.  It sat there, doing absolutely nothing.  I decided to let it continue doing that for a while.  I came back over an hour later and, miracle of miracles, it was actually formatted (apparently it uses a FAT32 file system)! 

Here’s the real kicker.  I unhooked it, it did its usual thing, and then I reconnected it.  While my MP3s were obviously gone, its original file structure was there with all the usual folders.  That means that the Clip has the ability to restore its factory-built file structure from firmware, and that bricked Clips could easily be restored (at the expense of stored data, obviously) by simply providing some kind of hardware-based user interface to trigger that functionality.

My 6-year-old daughter’s $10 no-name bargain-basement 512MB MP3 player has gone a year without a single problem.  My 3 SanDisk products (all several times more expensive) have all failed badly in that time and the company has failed even worse by consistently offering absolutely abysmal customer service.  Guess whose products I will never, ever buy again.

It’s a shame you didn’t find the forum sooner.  Every issue you mention has been discussed here, along with the requisite steps to resolve the issue.

If you browse the feedback from most any other player, you will find that these difficulties are not unique to SanDisk products, but you will find that manufacturer assistance is better from SanDisk than most.

This forum is sponsored by SanDisk, and offers a unique availablilty of technical expertise and feedback.  Many other manufacturers don’t offer the same openness and availability.

Support is only a telephone call away.  As long as cool heads prevail, you’ll find that they are most helpful.

Bob  :smileyvery-happy:

The help is no good if the same problem keeps coming up. I’m just tired of the same old thing. I’m also thinking of changing brands 

But if you post the issue here, someone might even be able to suggest a solution that fixes the issue permanently, for both you and others . . . . :wink:

@wirenut2 wrote:

The help is no good if the same problem keeps coming up. I’m just tired of the same old thing. I’m also thinking of changing brands 

As well a “me too” tacked onto a 2 1/2 year-old thread is no help to those who might be able to assist you with your particular problem. Approximately 10% of those who say “I’ve got the same exact problem” actually do. :wink:

And I’ve tried the “I’m just tired of the same old thing” too . . . my wife said, “Tough, you’re stuck with me now!” :stuck_out_tongue: