CLIP Locked up now not recognized by computer

I plugged my Sansa Clip up to my iMAC tonight to charge (first time on this machine).  Once it was done, I removed it but forgot to unmount it and in doing so it locked up.  I performed the soft reset by holding the power button up for 15+ seconds and it successfully shut down.  But it would not reboot when I turned it back on and now neither windows or mac recognizes the unit.  

Any ideas on how to resolve or does it need to be tossed? 

Can you try another reset?  Or try to force an MSC connection (Clip off and on hold, hold the center button down while connecting the Clip to your computer).

I tried the soft reset as well as turning on the unit and holding the center button down while connecting to the iMAC again…and nothing.  Tried it three different times and held the center button for over a minute and nothing happened.

Any way to force a hard reset?



When you tried forcing the MSC connection, was the Clip off and in the hold state (on switch all the way down, so that the orange under the on switch shows)?  (That’s what’s needed to try to force an MSC connection.)  Note:  this is how you do it with a PC; I’m not sure if this works with an iMac as well (perhaps an iMac owner has experience here and can say). 

That was the difference…I did not have the switch in the down position when I connected.  I put it down, held the center button, and whalla!  Thanks for the assistance!

That’s great to hear–congratulations!  Macs scare me, in terms of the interactions with the Clip if one isn’t following the protocol that’s needed …