Loading albums/songs - then not all will show up on Sansa Clip


My problem: I have the 4GB Sansa Clip. Just bought it today. First I tried to put several albums from one artist on Sansa Clip. Once the copying of files was done, I tried to do the same for second artist. Then I tried to listen to music through Sansa. The second artist was not loaded at all. Not all albums were loaded from the first artist. I did some research and then I found out that I might want to reformat the Sansa clip first. So I did and then I did the same with different artists and albums. This time only few songs uploaded to Sansa. Then I tried to load just song by song, then I tried to load only one album, then I tried different artists, etc…Always having similar problem of being able to upload only some albums or songs. So i went back to Best Buy to get second Sansa Clip. Same problem with the second one. Can anyone help me? 

Some background on my library:

All songs are MP3

90%+ of my albums are burned from my CDs. Some are from old P2P downloads.

I do not believe any are corrupted. When these forums and support pages says make sure your files are not corrupted they just mean digitally of course, correct? All my songs are playign fine on a computer or my wife’s iPod. 

Please Help


Did you check that the songs are all tagged properly.

What means properly? I am not tech savvy. 

All i know i have these songs in my iTunes for some time. Some time ago (several months) I worked whole weekend on properly naming my MP3s in iTunes - meaning I named all songs, artists, albums, etc. So the tag should be automatically updated through iTunes. Therefore i am assuming the answer to your question, is yes i have all (99% at least) of songs properly tagged. 

When i move the songs to Sansa i simply drag them over or copy and paste. Seems to be working, but then “No Songs” message. 

All together i tried this with over 15 artists = about 40 albums. I always end up only with few albums at most on Sansa. 

I will try to reset and upgrade firmware and check the tagging issue tonight, but i do not think that is the problem. Any other suggestions are welcome. 


If the file is a tru mp3 file it will be found. if its actually and AAC file with a changed extension it will not work.

MP2 format or .mp4 format will not be playable either.