Lenovo - can a tablet (slowy) destroy an SD card?

(I mistakenly posted this in the German memory card forum first. I’d prefer to discuss here).

I’ve got a Lenovo Tab P10 (TB_X705F). In this tablet I used to have a SANDisk Ultra SDXC card (128GB) in “adoptable storage” mode. Some time around last October, the tablet started telling me “SD card from SANdisk is missing” after startup. I tried to figure out what was going on, but I didn’t see any actual problems, the card was seen in the device’s settings dialog and seemed to work fine. So I (wrongly) decided to ignore the error message which seemed to be a false positive.

… until end of last year, the SD card definitely stopped working. As the tablet wasn’t rooted and the SD card content in “adoptable” mode is encrypted, I was pretty much in despair. I was lucky to find this guide, and with the help of it and my Linux PC, was able to recover the data and restore in on a new SD card of the same type (while doing this I noticed that the SANdisk 128 SDXC card was no less than 6GB larger than the 128GB card from another manufacturer, but that doesn’t matter here).

The old SD card turned out to be broken beyond repair. It was readable (after all, I’d recovered the entire content), but any attempt to write it failed, both on android and the PC. I also couldn’t reformat it.

So far, so good. But this morning the tablet was again greeting me with the familiar “SD card from SANdisk is missing” message, after just ~3 months. So I’m pretty worried now - will this SD card be broken in another few weeks, too? And if yes, what’s going on inside this tablet?

can you please share the snap/screen shot of the error message received? Usually this notification will pop after removing and reinsertion of adaptable storage uSD card in device. so can you please confirm, have you tried this scenario before getting this error message? You can give “Forget” option if device displayed this popup so that you can start using the card without any interrupt. As you said you have taken backup of your data’s, so please format the card as “Portable - External” storage in PC or some other device and check once whether card detecting properly or not.

At the moment, the card seems to be working. I’ll capture a screen shot when I see it next time. The reason why I posted this here was, as described in the original post, that last time I ignored (“forget”) this message the card completely ceased to function after some time, and I’d rather not have this experience again.

I do have a backup, but restoring from this issue requires a full 128GB backup of the encrypted partition, which is a very expensive operation to make. Incremental backups aren’t possible. I can’t do this every week.

I’d prefer to keep the card formatted as adoptable storage, because that has a lot of practical advantages over “portable / external” formatting. Is there any evidence that SD cards formatted as adoptable storage would break or wear out sooner than conventionally formatted ones?