Ultra 128GB Micro SDXC-I won't read or write in Galaxy Tab S 10.5

Bought a SanDisk Ultra 128GB Micro SDXC-I to use in my Galaxy Tab S 10.5 (SM-T800) and it won’t work despite the device supporting 128GB Micro SDXC. It’ll mount, the device will recognise that there is space available (125GB free) but after a couple of seconds, the card become unusable, unable to read from or write to the card. It doesn’t matter if it’s a photo, music, video or application, it will always throw the same “Failed to move” error, and when you try to read the card, it shows that that there is nothing there, even though I know there are folders and videos. When you look in the settings at the memory available, it still shows that there is 125GB free. Other cards work fine in it including 32GB and 64GB SanDisk Ultra SDHC, so I know it’s not the slot causing problems.

The card works fine in my Galaxy S5 (SM-G900i) as well as my GoPro Hero3 Black and in my laptop (via supplied SD adaptor). I have tried unmounting and remounting the card, formatting the card with the Tab and also on my laptop but it results in the same outcome.

Anyone have any ideas as to why this is happening and what I can do about it?


Sorry, all I can suggest is return it to where you purchased it from, or conmtact SanDisk directly regarding a warranty replacement:



Have the same issue. Bought the card (SDSDQUAN-128G-G4A) on Amazon.fr and cannot use it in the galaxy tab S 10.5. I know that some old SD card had problem with android (and still?) but this one is from 2014 and is specifically sold as an android card.

I formated it with SD formater 4 (extFat) in Windows 7 using the Kingston MobileLite G4 and all seemed Ok. I transfered several files. I did a Chkdsk and it seems htat there is no issue.

As soon as i plug it in the Galaxy Tab, the card seems to corrupt. I can start an MKV but it stops a few seconds/minutes later.

When i tried to read them again on a PC i have the same issue (Chkdsk also tells me hte card is corrupted).

It seems the galaxy tab is corupting it (while transfering it’s android structure perhaps).

I tried also with an Ibasso DX100 (android 4.2) and same issue (corruption), but i am not sure it supports extFat.

Can it be a ROM issue (some ole incompatibility with android)? A fake card (on Amazon???)?


PS: what is the correct version to use on the Galaxy? SDSDQUA-0128G-G46A or SDSDQUAN-128G-G4A

with this:


it recommends SDSDQUA-128G-A46A but it seems to be the american version of the G4A.


nethermind, i don’t know what is the corresponding european product.

here they says it is equivalent to SDSDQUA-128G-G46A:


here they says it is equivalent to SDSDQUAN-128G-G4A:


Are they both the same?

And what is this SDSDQUAN-128G-FFP-A ??? same specs

What is SDSDQUAN-128G-FFP-A ??? same specs as SDSDQUAN-128G-G4A.

Newer version?

Which one can/should be used with Galaxy Tab S 10.5 ?

did some H2testW and…totally fake !!! I was almost sure it was sold by amazon when i purchased but it seems it was sold by another vendor.



Seems like it is just a faulty card. When attempting to transfer files over 3gb via a USB adapter the card will drop out and the transfer will fail at about the 3gb mark. Testing it in my GoPro ended with two servicable videos and 8 corupt. The data has been dedicated, but the files aren’t recognised and as such they are useless.