128 GB micro sd card not showing up.

4 days ago, I bought a 128 gb sandisk sd card. It was working well for those 4 days until today, when I tried to delete some folders from my sd card in my tablet and I got an error saying that my sd card was corrupted. So, I went on to format the sd card, afterwhich I tried to copy files from my tablet’s internal storage © to my tablet’s sd card (D). However, it was to no avail as the D drive had mysteriously disappeared.

So, I went on to take out the SD card from my tablet and tried to read it on my laptop with a card reader. The card reader itself is working fine (device drivers are up to date) as I can use it to read 2 of my other SD cards used for my phone and 3DS. I unchecked the box for “Hide empty drives” and tried to format the D drive but instead, I got this message: "Please insert a disc into D ", which really shouldn’t be happening. I tried to use chkdsk and change the device drive letter but it was all for naught. Troubleshooter also didn’t detect any problems.

Disk management gave me this:

disk.JPGWhat should I do? 

It was working so well until today so I really don’t think it’s corrupt yet (hopefully) :\