Just got my Sansa clip+. Doing my head in. Please help.....

Hiya,

I got my Clip+ yesterday, and I’m impressed with the sound, but I really need some help on the following problems please:

Drag and drop freezing:  It doesn’t seem to like some tracks at all. If I try to drop an album folder in on windows explorer (W7 Ultimate), it does maybe 2 or 3, and then locks up. The progress bar freezes, and eventually it times out. These are just normal MP3’s.  I can drag some of the individual tracks in, but then the one it got stuck on just won’t go in. Why is this? On one album there are 4 that won’t go across.

Can’t delete some folders: I’ll drag a folder in and it works OK, but when I try to delete it, it says I can’t, as it’s write protected, and the only way I’ve found to get rid is to format the clip+ and start again.

Folders not staying seperate: I’ll drop maybe 3 folders in, but on the music list they are all bunched together. For example, I dropped 3 metallica album folders in (also the ones that wouldn’t delete). Kill Em All, Ride the Lightening, and Master of Puppets. But they don’t stay seperate on the clip+. The order they will be in is:

01 - Hit The Lights

01 - Fight Fire With Fire

01 - Battery

02 - The Four Horsemen

02 - Ride The Lightening

02 - Master Of Puppets

Etc…

What do I need to do? My last MP3 player was about 5 years ago and that was straight forward.

I don’t want to return  it because I love the size of it, and the sound is pretty awesome, but I’ll need to if I can’t get a grip on it.

Cheeeeeeeeeeeeeers

Go to Settings/System Settings/USB and change it to MSC. That should make the Clip act like any other flash drive and make drag and drop simple. The other mode is MTP, which is meant to work with Windows Media Player and sometimes gets tangled with write protection and other weirdness–best avoided, IMHO. 

If you click down the music list, onto a second page, you will see Folders and you should be able to find your music the same way as on your computer. 

But like most newer mp3 players, the Clip also works via labels rather than folders. 

The Album, Artist, etc. lists you see are not folders. They are databases built from the ID3 tags–the electronic labels in the files themselves. Album lists every album title found among the mp3s. Etc. It looks like  your Metallica albums don’t have the Album field filled into the ID3 tag, or the Clip can’t read that field, so it’s finding Artist (Metallica) and Track Number and doing the best it can. 

This can be fixed pretty easily if you just bear with the one-time explanation below. 

Get the free program mp3tag. http://www.mp3tag.de/en/

When you install it let it add itself to context menus (an option while installing).

After it installs, open it and go to Tools/Options/Tags/Mpeg and under Write  choose ID3v2.3 and ISO-8859-1. (ISO-8859-1 is how Windows displays English language text.)  Make sure those options are saved.

Tagging is not particularly standardized, and that will save tags the way the Clip likes them. 

Right-click on an album and look at the tags. Click on the Filename header to put them in order–since those seem to be working–and then fill in the other fields correctly. You can label the whole album at once by highlighting everything and putting Artist, Album, etc. in the box on the left. Obviously make sure Album is in the Album field. 

MP3 tag also has other nifty functions. One is Tools/Autonumbering Wizard. Make sure the files are in playing order, top to bottom, and choose the Leading Zeroes option. If an album has more than 10 tracks and they are labeled, 1, 2, 3, etc., the Clip will play 1, 11, 12, 13, before 2.   Leading Zeroes fixes that.

Under Convert you can convert your filenames into tags.  It’s pretty obvious how it works, each field is shown by %Artist%, etc.  So in the Convert box you could type  %Track% - %Title%  and will fill them in from your filenames.  That might be your easiest option, but mp3tag is very flexible and you should figure something out.

It’s best to take problem files off the Clip, fix them on the computer and send them back. You might just want to format it and start again. If you haven’t freshly formatted the whole unit, you can delete MTABLE.SYS from the Clip–that’s the database from the ID3 tags–and when you unplug it will make a new MTABLE.SYS from your new tags.

Going forward, it takes about 5 seconds to make sure Artist and Album are consistent on the whole album and run the Auto-Numbering Wizard  before you add the album  to the Clip. Then you can seek…and destroy.

Hahahah your last line made my chuckle.

Nice 1 Black Rectangle.

I changed the USB thing to MSC, and had a bit of a panic when it didn’t show the “internal memory” thing on explorer, but I realise now it doesn’t need it.

Weird one. The tracks that wouldn’t carry across still freeze up, but when I then unplug the clip and plug it back in, they are there! It’s a bit of a pain, but at least they are on there.

-Edit- Ah crap. No they aren’t. They play for a bit then jump to the next tune. Argh!!

I’ve installed MP3tag, and I’m having a mess about with it now. I’m not even 50% sure what I’m doing with it, but I’ll have a play around with it.

Thanks very much for your help ;^)

Looks like you were in MTP mode, which should stand for Makes Trouble Plenty.  MSC mode shows the Clip as one drive and the microSD card slot as a second one.

SanDisk assumed that people would use Windows Media Player as music library software, a la iTunes and doPi players, and Auto goes to MTP mode if WMP is on your computer. That’s why you have to force it into MSC, which gets WMP out of the way. But at least you have the option to do that .

I’d suggest you Format the unit again to get all the MTP stuff out of there. Then run each album through mp3tag and send it over.

If the albums were ripped on iTunes OSX then each album also includes a subfolder called MACOSX with filenames like ._01-Kill 'Em All.mp3.  Note the period underscore that starts them. Those aren’t mp3s, they are Apple finder files, 1kb in size. But because they have the .mp3 ending, the Clip tries to play them–shows the title but there’s no music in there. You should delete all MACOSX folders and contents from the Clip. (And if you have a Windows computer, they don’t need to be there either.)  It’s just another cute way Apple won’t play nicely with the other children.

Otherwise, playing partway through is weird unless something happened during the transfer. Try a different USB port. (You could also try a different mini-USB cord if you have one from a camera or something.)

It’s conceivable that you got a dud unit and it should go back to SanDisk. If a reformat and well-tagged files don’t work correctly, it should go back.  But try mp3tag first and send an album or two over at a time.

Nice 1 again thanks. I’ve decided to persevere with it. It does have cracking sound, ands when it does what I want it to, it does it well.

Thanks again for all your help.

Really, clear it off (you can do Settings/System Settings/Format as long as you have your music elsewhere).

Run each album through mp3tag to make sure the tags are consistent.

Make sure Settings/System Settings/USB Mode is MSC.

Then drag over one album at a time and…welcome home (sanitarium).