Newbie with a few problems

Just bought the Clip and charged it. When trying to open folders it takes forever to open them (30-45 seconds), for the first time I saw a green line running across the adress bar (when opened in My Computer) like it is a web page loading. I am runnig Vista on Intel quad core and 4 GB of ram so it’s not a slow computer.

When trying drag and drop songs it gets stuck copying. Then after I cancel it a minute or so later a window titled Computer/Sansa Clip 2GB pops up and starts loading again but loads the green line almost all the way and gets stuck. ( I tried it in both MSC and MTP modes)

I tried to install drivers from CD but it only responds if I try to install rhapsody, in fact I don’t even see anything else to install, there is the picture of the Clip but not clickable.

I tried to download firmware update but it too goes up to 50% and gets stuck.

Now Windows media won’t open at all.

help please


Right as I was trying to post the post above Explorer froze and only resumed when I unplugged the Clip. Then although it got stuck on first song when copying a 130 song folder it did copy 5 songs, is this thing possesed or am I just retarded?

To be honest its hard to tell sometimes what causes these issues. Things to consider and report back so we can help better…

  1. what version of Vista?

  2. What version of Windows Media?

  3. What is the firmware?

  4. What transfer method are you using?

  5. What USB mode (You said you tried a both but not what one you are using)?

  6. What file format are you songs in?

Let us know.