Ixpand troubleshoot problem

I’ve been using ixpand drive for 4 months now. I’ve moved most of my pictures and videos into the drive. My storage has been full again and yesterday i plugged it to move some more items into the drive. It’s been showing troubleshooting since now. I’ve tried signing out from my icloud, airplane mode on and off, restarted my device, cleared 8 gb of storage and all. But it’s still the same. I’ve experienced this troubleshoot problem many times. But it fixed easily except this time. I really want the datas in it safe and i want to urgently move some files into the drive to free up my device. Please give me solutions

1 Like

Hi @Shada
Have you opened a Support Case? If not opened, for more information, please contact the SD Technical Support team for best assistance and troubleshooting:

1 Like

If your SanDisk iXpand isn’t working, try these steps:

  1. Check Compatibility: Ensure your device is compatible with iXpand.
  2. Restart Devices: Restart your iPhone, iPad, or computer.
  3. Update Software: Ensure iXpand and device firmware are up-to-date.
  4. Check Connections: Securely connect iXpand to your device.

@evering01 thanks for this information :smiling_face: