iXpand drive dead

I purchased the 128GB model from Amazon on aug 29, 2017. My iXpand drive was working just fine yesterday. Today, I tried to plug it into my iPhone, and the phone cannot detect the iXpand drive. I tried to plug it into my Mac’s USB port, and it doesn’t detect it either. Plus, the iXpand Drive heats up significantly on my Mac after being plugged in for only 20 seconds, and data isn’t even being transferred between the stick and the Mac. 

My iXpand drive has all videos and I have some personal pictures on the SanDisk SecureAcess Vault that came with the iXpand drive. How can i recover all of my data? I would hate to lose my files as they are significantly important to me.

if it is not detected by the computer or an iOS device you would need to send it to a company that provides data recovery services. 

Did you find resolution to this ?  I bought mine end of Nov 2017.  The exact same thing happened to me. It worked one day and didn’t the next. I moved a ton of photos/videos to it and a few days later plugged it in so I could move them to a second drive to make sure i had a backup but now I don’t see any of the photos/videos…and my Mac, Iphone and PC does not even recognize the drive.  Before I call SanDisk in hopes they will pay to get the data off the drive I wanted to see if you figured out the issue. 

Lorrie Elliott 

data recovery is not covered by the warranty of any storage manufacturer. sandisk will replace the drive if it has failed but if you do not have a backup of the data you would need to seek data recovery services at your own expense. 

That’s really sad.  I went in the next day to back it up but it died from one use to the next so didn’t have the opportunity to back up. Weird. Sure do wish they’d stand by their brand. :-(.  Thanks for the quick resonse.