It wont turn on? Please help!!

I cant get the mp3 player to turn on…i have tried to reformat and changed battery…still nothing. It does light up when plugged into the computer. need help!!

Are you heaing any error messages (noices) when trying to turn on the Shaker?

Does it show up on your computer when you connect it?

Try a brand new battey it should actually turn on. Even when you have corrupted data on it.

I am having the same problem.  I get no sounds or light up of the ring around the Play/Pause/On/Off button when I try to turn the Sansa Shaker on.  No error messages at all.  

It does show up on my computer when I connect it.  And the ring around the Play/Pause/On/Off button DOES light up when it is connected.  I can also interact with the files on the mounted device.

I tried a brand new battery and it is still not turning on.

It almost seems like the Play/Pause/On/Off button itself is no longer working.  Have other customers experienced that type of problem with the Sansa Shaker? 

Hey! Same problem… any fixes?

Oh, this is my second problem and it’s only been out of the package for less than 10 hours!

Try to press the menu button as hard as you can and hold it untill it turns on that problem happened to me all the time and that helpedme so i hope it helps you.