it lights up for a second then nothing

My cruzer will light up when i plug it in for a second and but then it turns off and my comp never acknowledges its existance. anyone have any idea what thats about. it was working fine a couple weeks ago.

if this happens on multiple computers it is bad and will need to be replaced. if you are still within warranty i would suggest contacting sandisk technical support

any way to get the data off of it?

Only if you can find a machine that will acknowledge it’s existance.

you could send it to a company that provides data recovery services. try visiting 

This tip from a recent LangaList column might help"

_‘Windows can’t see an external USB drive,’ I have had similar problems with my multiple USB drives and Windows 7.

"I found that the solution was to go into Control Panel, Administrative Tools, Computer Management, Storage, and then Disk Management.

"Once I got there, my USB drive showed up in the right-lower panel — but I had to scroll down to see it. It did not have a drive letter.

“From there, it was a simple task to right-click the USB drive image, click Change Drive Letter and Paths, and assign a path. Like magic, the system recognized the external drive.”_


I’m having the same issue with a brand new drive.

I tried your tip Ed and it wasn’t worth it. All my drives except the Cruzer show up.

I just got a used SSD (seagate onetouch 500gb) and have same/similar issues. The interface is microUSB 3.0, when plugged in (multiple cables & computers tried), the drive produced an instantaneous flash of light then off and is never recognized by any computers. HOWEVER! if I plug in a regular microUSB (ie the normal one that does have the extra set of pins microUSB 3.0 has), the drive powers on and functions normal…albeit slower read/write speed, but at least data is accessible?

to my understanding this must mean there’s some kind of short or broken circuit caused by the extra pin connectors of the microUSB 3.0 that is avoided by using just the standard microUSB portion of the connector…

I wonder if you issue might be similar?