"[Insert3] returned 0xC00D2779" error message when trying to download audiobooks?

I use my Clip only to download audiobooks from the BPL website. Today, when I tried to download a book, I got an error message when I tried to transfer the file to my Sansa Clip. It says “[Insert3] returned 0xC00D2779,” and it occurs not when I download the book from the website to my computer, but when I then try to transfer the book from my computer to my Clip using the Overdrive Media Console. I see that 0xC00D2779 seems to mean “The file could not be transferred because the device clock is not set,” and based on advice I got another forum, I made sure I had WMP11 and then tried to bring up the reset clock message while syncing the device from there.  No luck – I couldn’t even bring up the prompt to reset my device’s clock.  I’ve also upgraded to .20 after spending an hour on this forum.  Arrrrrrrrrr, it’s driving me nuts!  Thanks for all help.

Did you format the Clip in Windows Media Player after telling it to set the secure clock?

Thanks for the response.  Formatting would erase whatever is on there right now, right?  I’m trying to avoid that, since the audiobooks I check out have expiration dates, and I need to listen to them first before I delete them.  If it’s absolutely necessary, of course, I’ll format it, but I was hoping someone would be able to suggest a workaround without the need to format.

Okay, now I’ve formatted the Clip on WMP 11 and on the device itself, and there’s no more data on it, but I still can’t bring up the clock to reset (assuming this really is my problem!).  I’m at my wits end.  Any other tips would be greatly appreciated.

I am getting the same message when I download books, but I can download ripped music.  Any Ideas?  I have been having this problem since 2/23

My father just started receiving the same message on his e260.  I tried quite a few things but the only thing that worked was connect the device in MSC mode, go into the SYSTEM folder, delete the file STORE.HDS, and then reconnect the player in MTP mode and re-synchronize.  Now everything is back to normal.  I’m not sure if the files or directory structure are similar on the Clip, but I wanted to suggest it as one more thing to try, for those of you who are as frustrated with this problem as I was!

*Hint - the SYSTEM folder is hidden.  If you’re not already set up to view hidden files and folders, you’ll first have to go into Windows Explorer, Tools menu, Folder Options.  Then click the View tab and select “Show hidden files and folders.”  Then click OK.   


Thanks for the suggestion, Zhanna.  After much tinkering with the thing, I finally gave up and returned it to the store I bought it from.  They gave me a new one, no questions asked.  Thus far it seems to be working okay, but I’ll keep your fix in mind if this one starts to act up too.

I have Sansa E250 with the same error message. Tried to follow your instructions but there was no System folder in the Sansa. Show Hidden files is checked and Hide system files unchecked but still no System folder visible in the Sansa.


I had the same thing on my computer at work with both my Clip and m240.  Both worked just fine when I downloaded the files on either of the home computers and loaded onto the players.  I’ll bet has something to do with the firewalls the guys at work set up and access to the network’s internal clock.  Hope this helps.

my niece fixed this for me will find out how she did it.dpiki@aol.com