Indicates it is charging, but nothing

Once it took many hours, but the Sansa Express 2GB supposedly fully charged.  It discharged fairly quickly since I use it to download books from the library.  Now I tried to recharge it seems to stay at 9%.  I have had it charging for well over an hour now with no chage.

It reads that it is connected and then says it is charging, but no results.  How long is this process supposed to last?

Thanks for any assistance you can give me.

Not much help in knowing how long its takes to charge, but I noticed this.


When I first got the little SE, the display used to change from ‘Charging’ to ‘Charged’. That was way back in January.

I wasn’t using it for few months; then couple of days ago I tried charging it. But even after three hours, the display won’t change from ‘Charging’ to ‘Charged’.  In the Windows Explorer, right clicking on the Sansa icon and selecting ‘properties’ show the charge as a % figure.  But it didn’t change. Stuck at 96% in my case. Then I took out the SE from the PC and plugged it back in again after 10 seconds. Then the ‘properties’ showed 100%.  But the display continued to show ‘Charging’ and not ‘Charged’ as it should at 100%


May be ‘Charged’ will appear on the display only with new batteries and not after sometime when the max capacity drop (as is normal with batteries).


Have you tried taking it out and plugging back again as I did? ?

Hi Blue Max,

Thanks for your input.  My SE shows the same as your’s did.  When I did bring it back up later the % showed up 100% and seems to be working.  I got a reply from the moderator who mentioned it takes 3.5 to 4.0 hours to recharge the battery.  Wow, makes me think about good old AAA batteries!  Again, many thanks for answering my plea for help.  Jean


" … it takes 3.5 to 4.0 hours to recharge the battery. "

Thanks for letting me know.



thank you for this.

my sansa started doing this today after i upgraded firmware and now it appears fully charged :slight_smile: