Not Charging

My Express has an empty battery. As i plug it to pc it doesn’t charge. I see the device as a disk but it says disk is not formated. I plugged in mtp mode or msc mode. i tried to update firmware but the updater didn’t start. I tried recovery tool and it didn’t work too. Does anybody know something about that?

what the heck no answer from anybody.  i have similar problem except my sansa heats up like it is charging but when i unplug it its not charged.  in fact it never goes into charging mode it is stuck at connected where it seems to be trying to sinc or something.  that is usually the first screen when i plug it in.  have you found any help elsewhere? 

aloha do you have to have a recipt to get a replacement for your sansa?

Try this:

Also, the Recovery Tool only works on the Connect, and won’t talk to any other player. 

i appreciate that information but i guess i forgot to mention an important point.  most of the time i plug my sansa into my computer it does nothing.   nothing on the screen no action at all.  so i tried that info from that fourm but it does not help me.  any other suggestions?

Have you had anyone respond yet?  I’m having a similar problem, but not quite.  It seems to take hours to charge—if indeed it is actually charging.

some people seem to be trying to help i only posted two days ago i think.

if its charging the display should light up and indicate its charging

is it doing that?